Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1111650 - atlas build completed on powerpc with make [IPTtune] Error 2
Summary: atlas build completed on powerpc with make [IPTtune] Error 2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: atlas
Version: 22
Hardware: powerpc
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Frantisek Kluknavsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-06-20 16:03 UTC by Michel Normand
Modified: 2015-11-27 16:54 UTC (History)
5 users (show)

Fixed In Version: atlas-3.10.1-21.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-27 16:54:09 UTC


Attachments (Terms of Use)
atlas.Make_ttune_arch_suffix.patch (deleted)
2014-06-20 16:06 UTC, Michel Normand
no flags Details | Diff
atlas.disable_error_pragma_decatomic.patch (deleted)
2014-06-20 16:07 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-06-20 16:03:19 UTC
Description of problem: atlas build completed on powerpc with make  [IPTtune] Error 2

Version-Release number of selected component (if applicable):
atlas-3.10.1-12.fc21

Steps to Reproduce:
1. fedpkg clone -a atlas
2. fedpkg mockbuild

Actual results:
grep of http://ppc.koji.fedoraproject.org/kojifiles/packages/atlas/3.10.1/10.fc21/data/logs/ppc64/build.log
===
build.log:15720:make[7]: *** [ATL_ResetAtomicCount_amd64.o] Error 1
build.log:15722:make[6]: *** [xprobe_atomic_amd64] Error 2
build.log:15797:make[7]: *** [ATL_ResetAtomicCount_win64.o] Error 1
build.log:15799:make[6]: *** [xprobe_atomic_win64] Error 2
build.log:15876:make[7]: *** [ATL_ResetAtomicCount_ia32.o] Error 1
build.log:15878:make[6]: *** [xprobe_atomic_ia32] Error 2
build.log:15946:make[7]: *** [ATL_ResetAtomicCount_sparc.o] Error 1
build.log:15948:make[6]: *** [xprobe_atomic_sparc] Error 2
build.log:16016:make[7]: *** [ATL_ResetAtomicCount_mips.o] Error 1
build.log:16018:make[6]: *** [xprobe_atomic_mips] Error 2
build.log:16264:make[7]: *** [ATL_ResetAtomicCount_amd64.o] Error 1
build.log:16266:make[6]: *** [xprobe_atomic_amd64] Error 2
build.log:16341:make[7]: *** [ATL_ResetAtomicCount_win64.o] Error 1
build.log:16343:make[6]: *** [xprobe_atomic_win64] Error 2
build.log:16420:make[7]: *** [ATL_ResetAtomicCount_ia32.o] Error 1
build.log:16422:make[6]: *** [xprobe_atomic_ia32] Error 2
build.log:16490:make[7]: *** [ATL_ResetAtomicCount_sparc.o] Error 1
build.log:16492:make[6]: *** [xprobe_atomic_sparc] Error 2
build.log:16560:make[7]: *** [ATL_ResetAtomicCount_mips.o] Error 1
build.log:16562:make[6]: *** [xprobe_atomic_mips] Error 2
build.log:16631:make[5]: *** [xtune_count] Error 2
build.log:16634:make[4]: *** [iTune_atomic] Error 127
build.log:16636:make[3]: *** [IThreadTune] Error 2
build.log:16638:make[2]: *** [IPTtune] Error 2
===

Additional info:
The above reported make error seems not critical as the binary rpms are 
properly generated.

I am still investigating the required code changes with two draft patches
but not completed yet as hardcoded setup and build hang.
===
atlas.Make_ttune_arch_suffix.patch
atlas.disable_error_pragma_decatomic.patch
===

Comment 1 Michel Normand 2014-06-20 16:06:03 UTC
Created attachment 910819 [details]
atlas.Make_ttune_arch_suffix.patch

Comment 2 Michel Normand 2014-06-20 16:07:10 UTC
Created attachment 910820 [details]
atlas.disable_error_pragma_decatomic.patch

Comment 3 Michel Normand 2014-06-20 16:40:43 UTC
same errors for ppc64le archi (that need patches of rhbz #1080073

Comment 4 Fedora Admin XMLRPC Client 2014-07-26 17:14:55 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Fedora Admin XMLRPC Client 2014-07-28 07:46:11 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Fedora Admin XMLRPC Client 2014-07-28 07:47:22 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Jaroslav Reznik 2015-03-03 16:03:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 8 Rafael Fonseca 2015-08-13 15:30:20 UTC
Is this bug still valid? How is it different from [1]?

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1080073

Comment 9 Michel Normand 2015-08-13 17:40:39 UTC
(In reply to Rafael Fonseca from comment #8)
> Is this bug still valid? How is it different from [1]?
> 
> [1] https://bugzilla.redhat.com/show_bug.cgi?id=1080073

yes it is still valid
is addressing a specific error reporting during build
but that is not fatal to the build process.

and differ from (1) that have the functional patches.

Comment 10 Ngo Than 2015-11-27 16:54:09 UTC
it seems to be fixed in atlas-3.10.1-21.fc22
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=295205


Note You need to log in before you can comment on or make changes to this bug.