Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1111053 - Auto-config fails with "Error : CHECK_NRPE: Error - Could not complete SSL handshake" when RHSC engine is having a DNS resolvable hostname
Summary: Auto-config fails with "Error : CHECK_NRPE: Error - Could not complete SSL ha...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.Gluster
Version: master
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Alon Bar-Lev
QA Contact: SATHEESARAN
URL:
Whiteboard: infra
Depends On:
Blocks: 1110623 1111268 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-19 07:03 UTC by Darshan
Modified: 2016-02-10 19:22 UTC (History)
19 users (show)

Fixed In Version: ovirt-engine-3.5.0_rc1
Doc Type: Bug Fix
Doc Text:
Previously, attempting to run the auto-configuration script on a Red Hat Storage controller would fail under certain conditions, reporting an SSL handshake error. This would occur when Red Hat Storage nodes were edited to a Red Hat Enterprise Virtualization environment, the NRPE configuration was edited during the host deployment operation and the NRPE service was not updated following those changes. Now, the NRPE service is restarted if the NRPE configuration is changed during a host deployment operation to ensure any configuration changes are correctly updated, making it possible to perform auto-configuration successfully under these conditions.
Clone Of: 1110623
: 1111268 (view as bug list)
Environment:
Last Closed: 2015-01-19 06:20:33 UTC
oVirt Team: Infra
alonbl: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0173 normal SHIPPED_LIVE ovirt-host-deploy bug fix and enhancement update 2015-02-11 23:09:26 UTC
oVirt gerrit 28890 None None None Never
oVirt gerrit 28902 None None None Never

Description Darshan 2014-06-19 07:03:05 UTC
+++ This bug was initially created as a clone of Bug #1110623 +++

Description of problem:

Auto-config fails with "Error : CHECK_NRPE: Error - Could not complete SSL handshake" when RHSC engine uses a resolvable hostname. See below:

-----------
#  /usr/lib64/nagios/plugins/gluster/discovery.py -c 34cluster -H 10.70.42.229
Failed to execute NRPE command 'discoverhostparams' in host '10.70.42.203' 
Error : CHECK_NRPE: Error - Could not complete SSL handshake.
Make sure NPRE server in host '10.70.42.203' is configured to accept requests from Nagios server
-----------

Version-Release number of selected component (if applicable):

rhsc-3.0.0-0.10.el6_5.noarch
nagios-server-addons-0.1.3-3.el6rhs.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Install and setup RHSC + Nagios Server by following http://rhsm.pad.engineering.redhat.com/rhsc-nagios-release-denali-7
2. Make sure that the RHSC engine is having a DNS resolvable hostname (EX: dhcp43-180.lab.eng.blr.redhat.com)
3. Add a few RHS nodes to a 3.4 cluster from the UI
4. Now, execute the following auto-config script from the engine:
 # /usr/lib64/nagios/plugins/gluster/discovery.py -c <cluster-name> -H <ip-address>


Actual results: Auto-config script fails with the error mentioned above.


Expected results: Auto-config script should execute sucessfully and detect the changes in the cluster configurations.


Additional info: Restarting nrpe in ALL the RHS nodes seems to resolve the issue.

--- Additional comment from Alon Bar-Lev on 2014-06-18 10:31:21 EDT ---

Please move/duplicate to rhev/ovirt-host-deploy so I can add this to errata.

Comment 4 Darshan 2015-01-07 07:28:21 UTC
This bug is not exactly relevant to RHEVM, its a bug related to nagios monitoring used by RHSC. 

   However this can be verified by checking if "allowed_hosts" field in nrpe configutation file (/etc/nagios/nrpe.cfg) is updated with the engine's hostname after adding that node to RHEVM and nrpe service is running.

Comment 5 Darshan 2015-01-09 11:36:57 UTC
Please ignore the previous comment. The "allowed_host" entry is not set in case of RHEVM because Monitoring enable environment variable is not set. The variable is set only in RHSC.

Comment 6 SATHEESARAN 2015-01-19 05:59:51 UTC
As I had discussion with Sahina & Darshan, this bug couldn't be verified with RHEVM. This fix is for RHSC + Nagios environment and it couldn't be verified with RHEVM.

On the similar notes, we have closed the bug https://bugzilla.redhat.com/show_bug.cgi?id=1159298.

I would suggest to close this bug with NOTABUG as a resolution

Comment 7 Alon Bar-Lev 2015-01-19 06:20:33 UTC
this is the same version of ovirt-host-deploy, it can be verified, but not important for me.


Note You need to log in before you can comment on or make changes to this bug.