Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1110788 - Gwt debugger is extremely slow
Summary: Gwt debugger is extremely slow
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Alexander Wels
QA Contact: Pavel Novotny
URL:
Whiteboard: ux
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-18 12:53 UTC by Alona Kaplan
Modified: 2015-02-16 13:35 UTC (History)
8 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:35:11 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28872 None None None Never
oVirt gerrit 30710 master MERGED webadmin: GWT debug mode speedup. Never
oVirt gerrit 30866 ovirt-engine-3.5 MERGED webadmin: GWT debug mode speedup. Never
Red Hat Bugzilla 1114863 None None None Never

Internal Links: 1114863

Description Alona Kaplan 2014-06-18 12:53:39 UTC
Description of problem:
When running the application in debug mode everything works tremendously slow.
Each browser refresh takes ~5-~10min and using the application is nearly impossible.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Einav Cohen 2014-06-23 15:39:40 UTC
Alexander - should be in post with link to http://gerrit.ovirt.org/#/c/28872/?
[although to my understanding, the improvement that ^^^ brings is not enough, and additional improvement need to be looked into]

thanks.

Comment 2 Alexander Wels 2014-06-24 12:55:21 UTC
Yes I want to investigate more before declaring this fixed

Comment 4 Alexander Wels 2014-07-25 17:10:53 UTC
The latest patch posted should give a 4-5x speed improvement on logging into webadmin during GWT debug mode. It takes me around 50s now, which for now I am going to declare sufficiently quick to not be an issue anymore. We just need to verify that the changes I made don't cause any regressions.

Comment 6 Pavel Novotny 2014-09-11 14:00:22 UTC
From comment 4 I assume the performance issue in GWT debug mode is fixed for development environments.

As for QA, I can  verify this bug from "production" point of view - on RHEVM installed from RPMs where GWT debug mode is not enabled.

From what I understood, this patch changes the way how UI presenters are initialized:

- Before, all UI presenters (i.e., areas of the HTML application like main tabs, sub-tabs, etc.) were initialized when the Webadmin/UserPortal application was initialized - right after login.
- Now, UI presenters are initialized only "on demand", after they're activated (i.e., at the moment some main tab or sub-tab is accessed).

Which results in:
1) faster login, application is initialized quicker because it doesn't load all UI presenters
- Verified: login to RHEVM 3.5 is 3+ faster than to RHEVM 3.4 on the same HW (~3 seconds vs ~10 seconds)
2) slower loading of main tabs or sub-tabs when accessing them for the first time
- Verified: comparing to RHEVM 3.4, loading of a main tab or sub-tab time takes a bit more time at first, but then is fast as in 3.4

Moving to verified, rhevm-3.5.0-0.10.master.el6ev.noarch (vt2.2).

If you find something from above is not true or accurate, feel free to move this bug back to ON_QA.


Note You need to log in before you can comment on or make changes to this bug.