Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1110756 - 'NoneType' object is not iterable error when certificate validation fails
Summary: 'NoneType' object is not iterable error when certificate validation fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-18 11:30 UTC by Petr Beňas
Modified: 2015-02-11 17:48 UTC (History)
9 users (show)

Fixed In Version: rhevm-iso-uploader-3.5.0-0.2.master.el6_5
Doc Type: Bug Fix
Doc Text:
Previously, when using the ISO uploader with an invalid host name, the following error message returned: 'NoneType' object is not iterable. With this update, a more explanatory error message is displayed: ERROR: Unable to connect to REST API. Message: The host name "xxx" contained in the URL doesn't match any of the names in the server certificate. ERROR: Unable to get ISO domain data
Clone Of:
Environment:
Last Closed: 2015-02-11 17:48:50 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0191 normal SHIPPED_LIVE rhevm-iso-uploader bug fix and enhancement update 2015-02-11 22:38:19 UTC
oVirt gerrit 31383 master MERGED error handling: handle invalid host Never
oVirt gerrit 31404 ovirt-iso-uploader-3.5 MERGED error handling: handle invalid host Never

Description Petr Beňas 2014-06-18 11:30:59 UTC
Description of problem:


Version-Release number of selected component (if applicable):
ovirt-iso-uploader-3.5.0-0.0.master.20140605.gite89dcdf.el6.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
# engine-iso-uploader -i ISO_DOMAIN upload -r localhost /root/test.iso 
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: Unable to connect to REST API.  Message: The host name "localhost" contained in the URL doesn't match any of the names in the server certificate.
ERROR: 'NoneType' object is not iterable
INFO: Use the -h option to see usage.

Expected results:
The "ERROR: 'NoneType' object is not iterable" shouldn't be there. The rest of the error message looks ok.

Additional info:

Comment 2 Petr Beňas 2014-08-26 13:57:54 UTC
in 3.5.0-0.1.master.20140812133501.gita818d93.el6

Comment 6 errata-xmlrpc 2015-02-11 17:48:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0191.html


Note You need to log in before you can comment on or make changes to this bug.