Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 111068 - Kernel hangs under heavy network IO doing dd over proprietary filesystem
Summary: Kernel hangs under heavy network IO doing dd over proprietary filesystem
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-26 22:09 UTC by Abraham R Matthews
Modified: 2006-02-21 19:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:12 UTC


Attachments (Terms of Use)

Description Abraham R Matthews 2003-11-26 22:09:06 UTC
Description of problem:
However in do_try_to_free_pages() (mm/vmscan.c) there is no call
to refill_freelist(). It looks like the call to refill_freelist()
was mistakenly removed when do_try_to_free_pages() cloned into
do_try_to_free_pages_kswapd(). (Maybe refill_freelist() was to be
removed in do_try_to_free_pages_kswapd() ?).

FWIW, in 2.4.18-19.7.x there is a call to refill_freelist() from
do_try_to_free_pages().

This results in a kernel hang when the workload recycles lots of
pages.

When we added the missing call to refill_freelist() in
do_try_to_free_pages(), the test was succesfull and the kernel did
not hang.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.20-20.7

How reproducible:
Every time.

Steps to Reproduce:
1. Install Panasas proprietary filesystem and mount network based 
filesystem.
2. Repeatedly do dd and cp to/from Panasas filesystem and 
from/to /dev/null.
3. Watch free pages dwindle till the kernel hangs.
  
Actual results:
Kernel is not responsive. Can ping the host, but can not ssh to it.
No response to keyboard. Does respond to sysrq magic keys.

Expected results:


Additional info:
Adding refill_freelist() in do_try_to_free_pages()(mm/vmscan.c:879)
ensured that there were free pages and the test completed.

Comment 1 Arjan van de Ven 2003-11-26 22:10:31 UTC

*** This bug has been marked as a duplicate of 78616 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.