Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1110625 - Stylesheet error while building AS testsuite on IBM jdk
Summary: Stylesheet error while building AS testsuite on IBM jdk
Keywords:
Status: CLOSED DUPLICATE of bug 1060051
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Dominik Pospisil
QA Contact: Pavel Jelinek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-18 05:57 UTC by Petr Kremensky
Modified: 2014-10-13 18:16 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-05 10:39:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Kremensky 2014-06-18 05:57:09 UTC
Description of problem:
I am unable to build 'Test Suite: Aggregator' module on IBM jdk due to stylesheet error.

ERROR:  '[ERR 0566][ERR XTSE0340] Only id() or key() can be used at the top level in match patterns: //*[local-name()='identity-provider' and starts-with(namespace-uri(), $pl-fed)]/@url is not a valid pattern.'
FATAL ERROR:  '[ERR 0512] Cannot continue because of stylesheet errors.'

Version-Release number of selected component (if applicable):
EAP 6.3.0.ER7

How reproducible:
Always

Steps to Reproduce:
 1. Run the AS testsuite using IBM jdk

Actual results:
[ERROR] Failed to execute goal org.codehaus.mojo:xml-maven-plugin:1.0:transform (ts.config-as.ip) on project jboss-as-testsuite: Failed to parse stylesheet javax.xml.transform.sax.SAXSource@3f9f14ae: com.ibm.xtq.xslt.jaxp.HandledRuntimeException: [ERR 0512] Cannot continue because of stylesheet errors.

Expected results:
No errors.

Additional info:
Workaround exists.
echo "javax.xml.transform.TransformerFactory=org.apache.xalan.processor.TransformerFactoryImpl" > ${JAVA_HOME}/jre/lib/jaxp.properties

Comment 1 Dominik Pospisil 2014-09-05 10:39:03 UTC
The issue has been allready fixed.

*** This bug has been marked as a duplicate of bug 1060051 ***

Comment 2 Dominik Pospisil 2014-09-05 10:39:46 UTC
The issue is a duplicete of 1060051 and has been fixed some time ago.


Note You need to log in before you can comment on or make changes to this bug.