Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1110623 - Auto-config fails to execute as NRPE is NOT set to restart after 'Add Host'
Summary: Auto-config fails to execute as NRPE is NOT set to restart after 'Add Host'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: RHGS 3.0.0
Assignee: Darshan
QA Contact: Prasanth
URL:
Whiteboard:
Depends On: 1111053 1111268
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-18 05:48 UTC by Prasanth
Modified: 2015-05-15 17:41 UTC (History)
9 users (show)

Fixed In Version: ovirt-host-deploy-1.2.2-1.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1111053 (view as bug list)
Environment:
Last Closed: 2014-09-22 19:11:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1277 normal SHIPPED_LIVE Red Hat Storage Console 3.0 enhancement and bug fix update 2014-09-22 23:06:30 UTC
oVirt gerrit 28890 master MERGED gluster: Restart nrpe nervice during host deploy. Never
oVirt gerrit 28902 ovirt-host-deploy-1.2 MERGED gluster: Restart nrpe nervice during host deploy. Never

Description Prasanth 2014-06-18 05:48:31 UTC
Description of problem:

Auto-config fails with "Error : CHECK_NRPE: Error - Could not complete SSL handshake" when RHSC engine uses a resolvable hostname. See below:

-----------
#  /usr/lib64/nagios/plugins/gluster/discovery.py -c 34cluster -H 10.70.42.229
Failed to execute NRPE command 'discoverhostparams' in host '10.70.42.203' 
Error : CHECK_NRPE: Error - Could not complete SSL handshake.
Make sure NPRE server in host '10.70.42.203' is configured to accept requests from Nagios server
-----------

Version-Release number of selected component (if applicable):

rhsc-3.0.0-0.10.el6_5.noarch
nagios-server-addons-0.1.3-3.el6rhs.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Install and setup RHSC + Nagios Server by following http://rhsm.pad.engineering.redhat.com/rhsc-nagios-release-denali-7
2. Make sure that the RHSC engine is having a DNS resolvable hostname (EX: dhcp43-180.lab.eng.blr.redhat.com)
3. Add a few RHS nodes to a 3.4 cluster from the UI
4. Now, execute the following auto-config script from the engine:
 # /usr/lib64/nagios/plugins/gluster/discovery.py -c <cluster-name> -H <ip-address>


Actual results: Auto-config script fails with the error mentioned above.


Expected results: Auto-config script should execute sucessfully and detect the changes in the cluster configurations.


Additional info: Restarting nrpe in ALL the RHS nodes seems to resolve the issue.

Comment 1 Alon Bar-Lev 2014-06-18 14:31:21 UTC
Please move/duplicate to rhev/ovirt-host-deploy so I can add this to errata.

Comment 2 Dusmant 2014-06-19 08:49:43 UTC
RHEV bug is : https://bugzilla.redhat.com/show_bug.cgi?id=1111053 and added dependency...

Comment 3 Prasanth 2014-06-26 14:08:19 UTC
Verified in ovirt-host-deploy-1.2.2-1.el6ev

------------------
# /usr/lib64/nagios/plugins/gluster/discovery.py -c ErrataCluster -H 10.70.43.90                                                                                
Cluster configurations changed                                                                                                                                                                
                                                                                                                                                                                              
Changes :                                                                                                                                                                                     
Hostgroup ErrataCluster - ADD                                                                                                                                                                 
Host ErrataCluster - ADD                                                                                                                                                                      
         Service - Volume Utilization - firstvol -ADD                                                                                                                                         
         Service - Volume Self-Heal - firstvol -ADD                                                                                                                                           
         Service - Volume Status - firstvol -ADD                                                                                                                                              
         Service - Volume Utilization - secondvol -ADD                                                                                                                                        
         Service - Volume Status - secondvol -ADD                                                                                                                                             
         Service - Cluster Utilization -ADD                                                                                                                                                   
         Service - Cluster - Quorum -ADD 
         Service - Cluster Auto Config -ADD 
Host dhcp43-90.lab.eng.blr.redhat.com - ADD
         Service - Brick Utilization - /rhs/brick1/first -ADD 
         Service - Brick - /rhs/brick1/first -ADD 
         Service - Brick Utilization - /rhs/brick2/second -ADD 
         Service - Brick - /rhs/brick2/second -ADD 
Host dhcp42-241.lab.eng.blr.redhat.com - ADD
         Service - Brick Utilization - /rhs/brick1/first -ADD 
         Service - Brick - /rhs/brick1/first -ADD 
         Service - Brick Utilization - /rhs/brick2/second -ADD 
         Service - Brick - /rhs/brick2/second -ADD 
Are you sure, you want to commit the changes? (Yes, No) [Yes]: 
Enter Nagios server address [rhs-client3.lab.eng.blr.redhat.com]: 
Cluster configurations synced successfully from host 10.70.43.90
Do you want to restart Nagios to start monitoring newly discovered entities? (Yes, No) [Yes]: 
Nagios re-started successfully
------------------

Comment 4 errata-xmlrpc 2014-09-22 19:11:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1277.html


Note You need to log in before you can comment on or make changes to this bug.