Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1110176 - [RFE] Improve Fencing Logic to Consider Storage and Network Validation
Summary: [RFE] Improve Fencing Logic to Consider Storage and Network Validation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Scott Herold
QA Contact: Shai Revivo
URL:
Whiteboard: infra
: 1118878 (view as bug list)
Depends On: 1110172 1117931 1117943 1118879 1119922 1119932 1120817 1120858 1188504 1190653
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-17 07:52 UTC by Scott Herold
Modified: 2016-02-10 19:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-27 13:28:59 UTC
oVirt Team: Infra
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)

Description Scott Herold 2014-06-17 07:52:53 UTC
Description of problem:
Today, our fencing logic tells one host to fence another over a fencing network and without any validation logic to determine if there are real host issues, or simply network connectivity issues.

How reproducible:
Seen multiple use cases at several customers

Steps to Reproduce:
1. Engine loses direct network connectivity and cannot see any host
2. Uplink switch loses network connectivity, breaking route between engine and host
3. Host loses direct network connectivity causing engine to see it as down

Actual results:
We need to add additional logic to make an attempt to validate a real issue and minimize the number of false positives introduced by today's fencing logic.

Expected results:
Improvement to fencing logic, knowing there is no way to have 100% accuracy

This BZ will be used to centralize the core fencing improvements and will have dependencies on Infra, Storage and Network components for the immediate solution.

Comment 1 Scott Herold 2014-07-17 18:40:29 UTC
Targeting tracker for RHEV 3.6.  Individual fencing logic checks will be targeted for 3.5 or 3.6 depending on dev capacity, and features will be introduced over 2 releases.

Comment 2 Scott Herold 2014-07-17 20:26:29 UTC
*** Bug 1118878 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.