Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 110986 - lynx not using utf-8
Summary: lynx not using utf-8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lynx
Version: 1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brian Brock
URL:
Whiteboard:
: 84781 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-26 11:49 UTC by Ales Ledvinka
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-01 13:48:47 UTC


Attachments (Terms of Use)

Description Ales Ledvinka 2003-11-26 11:49:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624

Description of problem:
modify /etc/lynx.cfg
remove /etc/lynx.cfg.cz
remove /etc/lynx.cfg.sk
have no idea what to do with /etc/lynx.cfg.jp


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fedora
2. rpm -i lynx*
3.
    

Additional info:

patch can be found at
http://portal.promon.cz/ledvinka/fedora/lynx-confguration-patch

one more option in question is assume-charset, but anyway it is
site/query dependant.

Comment 1 Tim Waugh 2003-11-27 09:58:14 UTC
*** Bug 84781 has been marked as a duplicate of this bug. ***

Comment 2 Thomas E. Dickey 2003-11-27 10:00:49 UTC
If lynx isn't compiled & linked against ncursesw, this patch
still won't do what is requested.

Comment 3 Tim Waugh 2003-11-27 17:30:22 UTC
Ales: did you test the patch?

Comment 4 Ales Ledvinka 2003-11-29 23:07:33 UTC
lynx in fedora is linked against ncursesw (thus i think it was
probably too soon marked as duplicate of 84781)

see http://portal.promon.cz/ledvinka/fedora/lynx/lynx-utf8-ldd
and http://portal.promon.cz/ledvinka/fedora/lynx/lynx-utf8-rpm-qR-lynx
and http://portal.promon.cz/ledvinka/fedora/lynx/lynx-utf8-rpm-q-lynx

http://portal.promon.cz/ledvinka/fedora/lynx/lynx-utf8-modules (not
using matroxfb)
http://portal.promon.cz/ledvinka/fedora/lynx/lynx-utf8-bash-set

for testing:
created cp1250 file with all possible national characters
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0035.JPG (ok)

iconv and display font got it right
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0040.JPG (ok)

generated other character sets
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0042.JPG (...)

using patched lynx.cfg with utf8
see the page which made me bugreport (now correctly displayed)
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0043.JPG (ok)

replace lynx.cfg with the version i got from fedora package and view
the page and see it is broken again.
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0045.JPG (bad)

still use lynx.cfg from fedora package and:
lynx -assume_local_charset=iso8859-1 lynx-utf8-test-88591.txt
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0046.JPG (...)
lynx -assume_local_charset=iso8859-2 lynx-utf8-test-88592.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0047.JPG (bad)
lynx -assume_local_charset=cp1250 lynx-utf8-test-cp1250.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0048.JPG (bad)
lynx -assume_local_charset=utf8 lynx-utf8-test-utf8.txt
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0049.JPG (bad)
(sorry for the quality of pictures... counting characters or looking
at layout you can see there are some missing)


rm /etc/lynx.cfg 
ln -s /etc/lynx.cfg.utf /etc/lynx.cfg
(use the patched lynx config)
lynx -assume_local_charset=iso8859-1 lynx-utf8-test-88591.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0050.JPG (...)
lynx -assume_local_charset=iso8859-2 lynx-utf8-test-88592.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0051.JPG (bad)
lynx -assume_local_charset=cp1250 lynx-utf8-test-cp1250.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0052.JPG (ok)
lynx -assume_local_charset=utf8 lynx-utf8-test-utf8.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0053.JPG (ok)
(or 53,54,55 - sorry it is terrible quality but i swear it is
correctly displayed)

hexdump of test files
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0056.JPG
(also availaible at
http://portal.promon.cz/ledvinka/fedora/lynx/lynx-utf8-test-*.txt)

replace lynx.cfg for lynx.cfg.cz from lynx package from fedora.
view the first page on which i noticed, that it is broken
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0057.JPG (bad)

still use lynx.cfg.cz config
lynx -assume_local_charset=iso8859-1 lynx-utf8-test-88591.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0061.JPG (...)
lynx -assume_local_charset=iso8859-2 lynx-utf8-test-88592.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0062.JPG (bad)
lynx -assume_local_charset=cp1250 lynx-utf8-test-cp1250.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0063.JPG (bad)
lynx -assume_local_charset=utf8 lynx-utf8-test-utf8.txt 
http://portal.promon.cz/ledvinka/fedora/lynx/DSCN0064.JPG (bad)

that is all for czech.

not sure about the .sk but if i remember correctly it is also 8859-2
and (but some more special characters - not sure if all are displayed
correctly)

Comment 5 Tim Waugh 2003-12-01 13:48:47 UTC
Fixed package is 2.8.5-14.


Note You need to log in before you can comment on or make changes to this bug.