Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1109766 - RHEV-Agent Windows builds are broken due to copying of files which should use backslashes in the win-guest-agent-build-exe.bat file
Summary: RHEV-Agent Windows builds are broken due to copying of files which should use...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks: 1109789 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-16 10:33 UTC by Vinzenz Feenstra [evilissimo]
Modified: 2015-02-17 08:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1109789 (view as bug list)
Environment:
Last Closed: 2015-02-17 08:28:41 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28788 None None None Never
oVirt gerrit 28794 None None None Never

Description Vinzenz Feenstra [evilissimo] 2014-06-16 10:33:51 UTC
Description of problem:
ovirt-guest-agent/win-guest-agent-build-exe.bat contains


How reproducible:
always during internal builds

Actual results:
The build fails due to the message "The syntax of the command is incorrect."

Expected results:
The build succeeds

Additional info:
        1 file(s) copied.
The syntax of the command is incorrect.
The syntax of the command is incorrect.
The syntax of the command is incorrect.
2014-06-15 04:44:21,859 [ERROR] koji.vm: error running build
Traceback (most recent call last):
  File "/home/RCM/bin/kojikamid", line 1070, in main
    results = build.run()
  File "/home/RCM/bin/kojikamid", line 836, in run
    self.build()
  File "/home/RCM/bin/kojikamid", line 692, in build
    self.bashBuild()
  File "/home/RCM/bin/kojikamid", line 782, in bashBuild
    raise BuildError, 'build command failed, see build.log for details'
BuildError: build command failed, see build.log for details

Comment 7 Vinzenz Feenstra [evilissimo] 2014-08-29 09:53:49 UTC
Verified: rhev-guest-tools-iso-3.5-1.el6_5.noarch.rpm are released with vt releases this fix was required to be able building the guest tools again

Comment 9 Omer Frenkel 2015-02-17 08:28:41 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.