Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1109548 - cluster-id option is missing in auto-completion, when create new template
Summary: cluster-id option is missing in auto-completion, when create new template
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Lukas Svaty
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-15 08:08 UTC by Artyom
Modified: 2015-02-17 08:28 UTC (History)
9 users (show)

Fixed In Version: rhevm-sdk-python-3.5.0.3-1.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 08:28:50 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29933 master MERGED restapi: Fix optional parameters of add template Never
oVirt gerrit 29965 ovirt-engine-3.5 MERGED restapi: Fix optional parameters of add template Never

Description Artyom 2014-06-15 08:08:33 UTC
Description of problem:
cluster-id option is missing in auto-completion, when you create new template

Version-Release number of selected component (if applicable):
av9.5

How reproducible:
Always

Steps to Reproduce:
1. Enter to rhevm-shell
2. Run command add template, click TAB, shell will show you auto-complete options
3.

Actual results:
No cluster-id

Expected results:
cluster-id must exist

Additional info:

Comment 1 Juan Hernández 2014-06-16 08:57:18 UTC
This happens because the cluster name and identifier aren't documented as optional parameters of the operation that adds a template. The RSDL metadata file rdsl_metadata.yaml file needs to be fixed. Once this is fixed the Python SDK needs to be regenerated. Once the Python SDK is regenerated the CLI will automatically support the option, no need to modify it.

Comment 2 Juan Hernández 2014-07-11 10:00:03 UTC
This is a simple fix in the metadata, so I'm taking it. Once the metadata is fixed the SDKs will need to be regenerated.

Comment 3 Juan Hernández 2014-07-14 08:44:37 UTC
The fix for this issue has been merged into the upstream 3.5 branch, so it will be available downstream with the next rebase.

Comment 4 Juan Hernández 2014-07-14 14:03:51 UTC
The Python SDK needs to be regenerated to complete the fix of this issue.

Comment 5 Lukas Svaty 2014-08-12 09:06:43 UTC
verified in rhevm-sdk-python-3.5.0.3-1.el6_5.noarch

Comment 6 Omer Frenkel 2015-02-17 08:28:50 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.