Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1108257 - subscription-manager release --list is empty on RHEL Workstation with product 71
Summary: subscription-manager release --list is empty on RHEL Workstation with product 71
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.11
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel511
TreeView+ depends on / blocked
 
Reported: 2014-06-11 15:38 UTC by John Sefler
Modified: 2014-09-16 00:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-16 00:23:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1225 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-09-16 04:15:23 UTC

Description John Sefler 2014-06-11 15:38:32 UTC
Description of problem:
On a RedHatEnterpriseLinuxClient5.11 installation with productId 71 installed and auto-subscribed, the subscription-manager release --list reports "No release versions available, please check subscriptions.".   This is an error because the rhsm.log reports:

2014-06-11 11:20:41,051 [DEBUG] subscription-manager @certdirectory.py:204 - Installed product IDs: ['71']
2014-06-11 11:20:41,051 [INFO] subscription-manager @release.py:70 - No products with RHEL product tags found

where the rhel5 workstation product tags are:

[root@cloud-qe-18 ~]# rct cat-cert /etc/pki/product/71.pem | grep Tags
	Tags: rhel-5-client-workstation,rhel-5-workstation

              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Failed to generically recognize these as a RHEL product tag.
Seems like we logic for a special case.


Version-Release number of selected component (if applicable):
[root@cloud-qe-18 ~]# rpm -q subscription-manager
subscription-manager-1.11.3-6.el5


How reproducible:


Steps to Reproduce:
[root@cloud-qe-18 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.11 Beta (Tikanga)

[root@cloud-qe-18 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com --autosubscribe
Username: qa@redhat.com
Password: 
The system has been registered with ID: b9e541a5-6953-439b-988d-2aa0113a5261 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Workstation
Status:       Subscribed

[root@cloud-qe-18 ~]# subscription-manager repos | grep "Enabled:   1" -B3
Repo ID:   rhel-5-workstation-rpms
Repo Name: Red Hat Enterprise Linux 5 Workstation (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/workstation/5/$releasever/$basearch/os
Enabled:   1
--
Repo ID:   rhel-5-workstation-desktop-rpms
Repo Name: Red Hat Enterprise Linux 5 Workstation - Desktop (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/workstation/5/$releasever/$basearch/desktop/os
Enabled:   1

[root@cloud-qe-18 ~]# ls /etc/pki/entitlement/
5197141426013364177-key.pem  5197141426013364177.pem

[root@cloud-qe-18 ~]# curl --stderr /dev/null --insecure --tlsv1 --cert /etc/pki/entitlement/5197141426013364177.pem --key /etc/pki/entitlement/5197141426013364177-key.pem https://cdn.redhat.com/content/dist/rhel/workstation/5/listing
5.10
5.7
5.8
5.9
5Client

[root@cloud-qe-18 ~]# subscription-manager release --list
No release versions available, please check subscriptions.



Actual results:
No release versions available, please check subscriptions.


Expected results:
5.10
5.7
5.8
5.9
5Client

Comment 1 RHEL Product and Program Management 2014-06-11 15:58:46 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 2 John Sefler 2014-06-11 18:17:23 UTC
Note that this bug is a regression from rhel510...

[root@cloud-qe-6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.15.3-1
subscription-manager: 1.8.22-1.el5
python-rhsm: 1.8.17-1.el5

[root@cloud-qe-6 ~]# subscription-manager  list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Workstation
Product ID:     71
Version:        5.10
Arch:           x86_64
Status:         Unknown
Status Details: 
Starts:         
Ends:    

[root@cloud-qe-6 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com --autosubscribe
Username: qa@redhat.com
Password: 
The system has been registered with ID: bd95f205-2de5-4fa5-b2d1-6ebaa9479e50 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Workstation
Status:       Subscribed

[root@cloud-qe-6 ~]# subscription-manager repos | grep "Enabled:   1" -B3

Repo ID:   rhel-5-workstation-rpms
Repo Name: Red Hat Enterprise Linux 5 Workstation (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/workstation/5/$releasever/$basearch/os
Enabled:   1
--
Repo ID:   rhel-5-workstation-desktop-rpms
Repo Name: Red Hat Enterprise Linux 5 Workstation - Desktop (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/workstation/5/$releasever/$basearch/desktop/os
Enabled:   1

[root@cloud-qe-6 ~]# ls /etc/pki/entitlement/
8214171141387049694-key.pem  8214171141387049694.pem

[root@cloud-qe-6 ~]# curl --stderr /dev/null --insecure --tlsv1 --cert /etc/pki/entitlement/8214171141387049694.pem --key /etc/pki/entitlement/8214171141387049694-key.pem https://cdn.redhat.com/content/dist/rhel/workstation/5/listing
5.10
5.7
5.8
5.9
5Client

[root@cloud-qe-6 ~]# subscription-manager release --list
+-------------------------------------------+
          Available Releases
+-------------------------------------------+
5.10
5.7
5.8
5.9
5Client



PASSED on rhel510 with subscription-manager-1.8.22-1.el5

Comment 4 Adrian Likins 2014-06-18 16:05:50 UTC
Is the entitlement cert 8214171141387049694.pem available?

Curious what required tags it's looking for.

Want to verify the product->content tag matches is correct as well.

Comment 5 Adrian Likins 2014-06-18 16:14:46 UTC
For product id 71 with tags "rhel-5-client-workstation,rhel-5-workstation", is it correct to assume it should still only match content for 'rhel-5-workstation' or 'rhel-5-client-workstation' ?

ie, not rhel-5 content?

And that 'rhel-5' product tag is not considered a match for a content tag of 'rhel-5-workstation'?

(See https://bugzilla.redhat.com/show_bug.cgi?id=861151 for related bug, that makes sure

Comment 8 John Sefler 2014-07-09 19:11:15 UTC
Verifying Version...

[root@cloud-qe-22 ~]# rpm -q subscription-manager
subscription-manager-1.11.3-8.el5
[root@cloud-qe-22 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.11 Beta (Tikanga)
[root@cloud-qe-22 ~]# rct cat-cert /etc/pki/product/71.pem | grep Tags
	Tags: rhel-5-client-workstation,rhel-5-workstation
[root@cloud-qe-22 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Workstation
Product ID:     71
Version:        5.11
Arch:           x86_64
Status:         Unknown
Status Details: 
Starts:         
Ends:           

[root@cloud-qe-22 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com --autosubscribe
Username: qa@redhat.com
Password: 
The system has been registered with ID: c9ea8ca1-61b4-489c-8e29-b72362157afb 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Workstation
Status:       Subscribed

[root@cloud-qe-22 ~]# subscription-manager repos | grep "Enabled:   1" -B3
Repo ID:   rhel-5-workstation-rpms
Repo Name: Red Hat Enterprise Linux 5 Workstation (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/workstation/5/$releasever/$basearch/os
Enabled:   1
--
Repo ID:   rhel-5-workstation-desktop-rpms
Repo Name: Red Hat Enterprise Linux 5 Workstation - Desktop (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/workstation/5/$releasever/$basearch/desktop/os
Enabled:   1
[root@cloud-qe-22 ~]# curl --stderr /dev/null --insecure --tlsv1 --cert /etc/pki/entitlement/5699015458438532307.pem --key /etc/pki/entitlement/5699015458438532307-key.pem https://cdn.redhat.com/content/dist/rhel/workstation/5/listing
5.10
5.7
5.8
5.9
5Client
[root@cloud-qe-22 ~]# subscription-manager release --list
+-------------------------------------------+
          Available Releases
+-------------------------------------------+
5.10
5.7
5.8
5.9
5Client
[root@cloud-qe-22 ~]# 

VERIFIED: "subscription-manager release --list" now reports the expected list on a Red Hat Enterprise Linux Workstation (productId 71 that provides Tags: rhel-5-client-workstation,rhel-5-workstation)

Comment 10 errata-xmlrpc 2014-09-16 00:23:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1225.html


Note You need to log in before you can comment on or make changes to this bug.