Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 110787 - unable to get OSA networking with z/VM SWITCH
Summary: unable to get OSA networking with z/VM SWITCH
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.2
Hardware: s390
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 16:00 UTC by Brock Organ
Modified: 2007-04-18 16:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:09 UTC


Attachments (Terms of Use)
text of email message describing problem (deleted)
2003-11-24 16:04 UTC, Brock Organ
no flags Details

Description Brock Organ 2003-11-24 16:00:22 UTC
* customer reported issue with 7.2-s390 product
* using z/VM Switch feature (new to z/VM 4.4)
* using OSA adapter (and corresponding OCO modules)

from email from customer:

I was able to get 7.32 working with z/VM VSWITCH. But I'm having a
problemsharing the OSA-Express between Linux instances. Below is what
I'm seeing and what IBM has recommended:

Recommended solution:

"Kerry It's either a bug in Linux or OSA.  While the MAC address on
sharedOSA is the same, my understanding is that the interface id (part
of thelink-local fe80 address) is constructed by combining the MAC
address witha unique-per-MAC value.  Either Linux didn't ask the OSA
for a uniquevalue, or the OSA card is returning the same value to
multiple instances.If you have built your own Linux kernel or drivers,
make sure you have'Prepare net_device struct for shared IPv6 cards' in
the kernelconfiguration menu set to "y".  This will set
"CONFIG_SHARED_IPV6_CARDS=y"which has to be present to cause Linux to
go get the unique-per-MAC value Ireferenced."

Problem:qdio: loading QDIO base support version 2 ($Revision: 1.78.2.6
         $/$Revision: 1.44.2.1 $)                                    
           debug: reserved 1 areas of 4 pages for debugging qdio_setup
            debug: qdio_setup: new level 2                           
              debug: reserved 2 areas of 4 pages for debugging
qdio_labs              debug: qdio_labs: new level 2                 
                         debug: reserved 1 areas of 2 pages for
debugging qdio_sense             debug: qdio_sense: new level 2      
                                   debug: reserved 2 areas of 4 pages
for debugging qdio_trace             debug: qdio_trace: new level 2  
                                       IPv6 v0.8 for NET4.0          
                                         IPv6 over IPv4 tunneling
driver                                         qeth: loading qeth
S/390 OSA-Express driver ($Revision: 1.136.2.6       $/$Revision:
1.53.2.2 $/$Revision: 1.18 $:IPv6)                          qeth:
allocated 0 spare buffers                                       
debug: reserved 1 areas of 8 pages for debugging qeth_setup          
  debug: qeth_setup: new level 3                                     
    debug: reserved 1 areas of 2 pages for debugging qeth_misc       
      debug: qeth_misc: new level 2                                  
        debug: reserved 1 areas of 8 pages for debugging qeth_data   
          debug: qeth_data: new level 2                              
            debug: reserved 2 areas of 8 pages for debugging
qeth_control           debug: qeth_control: new level 2              
                         debug: reserved 1 areas of 2 pages for
debugging qeth_sense             debug: qeth_sense: new level 2      
                                   debug: reserved 2 areas of 2 pages
for debugging qeth_qerr              debug: qeth_qerr: new level 2   
                                       debug: reserved 2 areas of 4
pages for debugging qeth_trace             debug: qeth_trace: new
level 2                                          qeth: Trying to use
card with devnos 0x3008/0x3009/0x300A               qeth: Device
0x3008/0x3009/0x300A is an OSD Express card (level: f4f0)  with link
type Gigabit Eth (portname: OSA01)                            qeth:
Trying to use card with devnos 0x13C/0x13D/0x13B                 
qeth: Device 0x13C/0x13D/0x13B is an OSD Express card (level: 0333)  
  with link type Gigabit Eth (portname: OSA04)                       
    qeth: Trying to use card with devnos 0x10C/0x10D/0x10B           
      qeth: Device 0x10C/0x10D/0x10B is an OSD Express card (level:
0333)     with link type Gigabit Eth (portname: OSA01)               
             qeth: QETH_IP_VERSION is 0                              
               qeth: skb->protocol=x806=2054                         
                 qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 6b fd  08
06 00 01            qeth: skb:08 00 06 04  00 01 00 02  55 9a 6b fd 
00 00 00 00            qeth: setip : return code 0xe005 (duplicate ip
address)                 qeth: was not able to set ip
fe80:0000:0000:0000:0202:55ff:fe9a:6bfd/10on irq x1 (result: 0xe005),
trying to continue                           qeth: setip : return code
0xe005 (duplicate ip address)                 qeth: removing IP from
local IP list                                   eth0: duplicate
address detected!                                        qeth:
QETH_IP_VERSION is 0                                             
qeth: skb->protocol=x806=2054                                        
  qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 6b fd  08 06 00 01       
    qeth: skb:08 00 06 04  00 01 00 02  55 9a 6b fd  00 00 00 00     
      qeth: QETH_IP_VERSION is 0                                     
        qeth: skb->protocol=x806=2054                                
          qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 6b fd  08 06 00 01
           qeth: skb:08 00 06 04  00 02 00 02  55 9a 6b fd  0a 4a 0b
38            qeth: setip : return code 0xe005 (duplicate ip address)
                qeth: was not able to set ip
fe80:0000:0000:0000:0202:55ff:fe9a:574d/10on irq x4 (result: 0xe005),
trying to continue                           qeth: setip : return code
0xe005 (duplicate ip address)                 qeth: removing IP from
local IP list                                    qeth: QETH_IP_VERSION
is 0                                              qeth:
skb->protocol=x806=2054                                          
qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 57 4d  08 06 00 01         
  qeth: skb:08 00 06 04  00 01 00 02  55 9a 57 4d  00 00 00 00       
   eth1: duplicate address detected!                                 
      qeth: QETH_IP_VERSION is 0                                     
        qeth: skb->protocol=x806=2054                                
          qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 57 4d  08 06 00 01
           qeth: skb:08 00 06 04  00 01 00 02  55 9a 57 4d  00 00 00
00            qeth: QETH_IP_VERSION is 0                             
                qeth: skb->protocol=x806=2054                        
                  qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 6b fd  08
06 00 01            qeth: skb:08 00 06 04  00 01 00 02  55 9a 6b fd 
0a 4a 0b 38            qeth: QETH_IP_VERSION is 0                    
                         qeth: skb->protocol=x806=2054               
                           qeth: skb:ff ff ff ff  ff ff 00 02  55 9a
57 4d  08 06 00 01            qeth: skb:08 00 06 04  00 02 00 02  55
9a 57 4d  0a 4a 0e 38            qeth: QETH_IP_VERSION is 0          
                                   qeth: skb->protocol=x806=2054     
                                     qeth: skb:ff ff ff ff  ff ff 00
02  55 9a 57 4d  08 06 00 01            qeth: skb:08 00 06 04  00 01
00 02  55 9a 57 4d  0a 4a 0e 38           eth2: no IPv6 routers
present                                           eth0: duplicate
address detected!                                       eth0:
duplicate address detected!                                      
eth1: duplicate address detected!                                    
  eth1: duplicate address detected!                                  
    eth0: duplicate address detected!                                
      eth0: duplicate address detected!                              
        eth1: duplicate address detected!                            
          eth1: duplicate address detected!                          
            eth0: duplicate address detected!                        
              eth0: duplicate address detected!                      
                eth1: duplicate address detected!                    
                  eth1: duplicate address detected!                  
                    eth0: duplicate address detected!                
                      eth1: duplicate address detected!              
                        eth0: duplicate address detected!            
                          eth0: duplicate address detected!          
                            eth1: duplicate address detected!        
                              eth1: duplicate address detected!      
                                eth0: duplicate address detected!    
                                  eth1: duplicate address detected!  
                                     qeth: QETH_IP_VERSION is 0      
                                       qeth: skb->protocol=x806=2054 
                                         qeth: skb:ff ff ff ff  ff ff
00 02  55 9a 6b fd  08 06 00 01            qeth: skb:08 00 06 04  00
01 00 02  55 9a 6b fd  00 00 00 00            qeth: QETH_IP_VERSION is
0                                              qeth:
skb->protocol=x806=2054                                          
qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 6b fd  08 06 00 01         
  qeth: skb:08 00 06 04  00 01 00 02  55 9a 6b fd  00 00 00 00       
    qeth: QETH_IP_VERSION is 0                                       
      qeth: skb->protocol=x806=2054                                  
        qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 6b fd  08 06 00 01 
          qeth: skb:08 00 06 04  00 02 00 02  55 9a 6b fd  0a 4a 0b 38
           qeth: QETH_IP_VERSION is 0                                
             qeth: skb->protocol=x806=2054                           
               qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 57 4d  08 06
00 01            qeth: skb:08 00 06 04  00 01 00 02  55 9a 57 4d  00
00 00 00            qeth: QETH_IP_VERSION is 0                       
                      qeth: skb->protocol=x806=2054                  
                        qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 57
4d  08 06 00 01            qeth: skb:08 00 06 04  00 01 00 02  55 9a
57 4d  00 00 00 00            qeth: QETH_IP_VERSION is 0             
                                qeth: skb->protocol=x806=2054        
                                  qeth: skb:ff ff ff ff  ff ff 00 02 
55 9a 6b fd  08 06 00 01            qeth: skb:08 00 06 04  00 01 00 02
 55 9a 6b fd  0a 4a 0b 38            qeth: QETH_IP_VERSION is 0      
                                       qeth: skb->protocol=x806=2054 
                                         qeth: skb:ff ff ff ff  ff ff
00 02  55 9a 57 4d  08 06 00 01            qeth: skb:08 00 06 04  00
02 00 02  55 9a 57 4d  0a 4a 0e 38            qeth: QETH_IP_VERSION is
0                                              qeth:
skb->protocol=x806=2054                                          
qeth: skb:ff ff ff ff  ff ff 00 02  55 9a 57 4d  08 06 00 01         
  qeth: skb:08 00 06 04  00 01 00 02  55 9a 57 4d  0a 4a 0e 38       
    qeth: setip : return code 0xe005 (duplicate ip address)          
      qeth: was not able to set ip
fe80:0000:0000:0000:0202:55ff:fe9a:574d/10
on irq x4 (result: 0xe005), trying to continue                       
   qeth: setip : return code 0xe005 (duplicate ip address)           
     qeth: removing IP from local IP list                            
       qeth: setip : return code 0xe005 (duplicate ip address)       
         qeth: was not able to set ip
fe80:0000:0000:0000:0202:55ff:fe9a:6bfd/10
on irq x1 (result: 0xe005), trying to continue                       
   qeth: setip : return code 0xe005 (duplicate ip address)           
     qeth: removing IP from local IP list                            
      eth0: no IPv6 routers present                                  
        eth1: no IPv6 routers present

Comment 1 Brock Organ 2003-11-24 16:01:44 UTC
sorry about the bad text formatting ... I'll make an attachment with
the text ... :\

Comment 2 Arjan van de Ven 2003-11-24 16:03:17 UTC
is this the driver we ship ?

Comment 3 Brock Organ 2003-11-24 16:04:32 UTC
Created attachment 96151 [details]
text of email message describing problem

Comment 4 Brock Organ 2003-11-24 16:06:03 UTC
for the OSA adapter this is the OCO modules from IBM (those modules
are now open source, but at the time of the 7.2-s390 release, they
were binary only) ...

Comment 5 Arjan van de Ven 2003-11-24 16:07:52 UTC
then it doesn't look like something we can help with...

*** This bug has been marked as a duplicate of 78616 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:00:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.