Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1107799 - Following Link to Marketplace in FF (29) Opens Marketplace in a Protected Window
Summary: Following Link to Marketplace in FF (29) Opens Marketplace in a Protected Window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Alexander Wels
QA Contact: Petr Kubica
URL:
Whiteboard: ux
Depends On:
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2014-06-10 16:25 UTC by Matt Reid
Modified: 2015-02-16 13:36 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Cause: The market place popup window did not have the appropriate parameters causing it to open up in a window with very little control for the user. Consequence: To the user it seemed the popup was not functioning properly. Fix: Added the appropriate options to the popup to allow control to the user. Result: The popup now functions normally and gives the user the ability to navigate as before.
Clone Of:
Environment:
Last Closed: 2015-02-16 13:36:22 UTC
oVirt Team: ---


Attachments (Terms of Use)
Protected Marketplace Window in FF (deleted)
2014-06-10 16:26 UTC, Matt Reid
no flags Details
Video showing the window that opens and trying to do things in it (deleted)
2014-06-10 16:27 UTC, Matt Reid
no flags Details
My Firefox Settings (deleted)
2014-06-30 15:34 UTC, Matt Reid
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29709 master MERGED webadmin: fix feedback link popup scrollbars Never
oVirt gerrit 30587 ovirt-engine-3.5 MERGED webadmin: fix feedback link popup scrollbars Never

Description Matt Reid 2014-06-10 16:25:58 UTC
Description of problem:
There's a link in RHEV to the Marketplace in the admin portal. Clicking it on FF (I'm running version 29) leads to opening a new window to the Marketplace, like I would expect, however, the window it spawns seems to be protected somehow, and not a normal FF window. There's no scroll bar, I can't use my mouse wheel to scroll the page, I can't change the URL in the address bar, and the only way I've gotten the page to scroll was using the arrow keys. You can click on links within the window, and the page will update, but when it reloads, it doesn't give you a scroll bar, or fix itself at all.

This happens to me on Fedora 20 with FF 29, as well as on a coworkers Mac (10.8 I think?), also running the latest FF.

Version-Release number of selected component (if applicable):
RHEV 3.3

How reproducible:
100%

Steps to Reproduce:
1. Log into RHEV using FF
2. Click on the Marketplace link

Actual results:
New window pops open to the Marketplace, but you can't do much with it

Expected results:
To be taken to the Marketplace in a normal tab, where I can scroll the page, change the URL and do other normal browsing activities

Additional info:

Comment 1 Matt Reid 2014-06-10 16:26:23 UTC
Created attachment 907324 [details]
Protected Marketplace Window in FF

Comment 2 Matt Reid 2014-06-10 16:27:41 UTC
Created attachment 907326 [details]
Video showing the window that opens and trying to do things in it

Comment 3 Einav Cohen 2014-06-27 22:33:04 UTC
I assume that we cannot force the page to open in a new tab, rather than a new window (see bug 917970, comment #2); Your browser is probably configured opening URLs in new windows, rather than new tabs, and we cannot control that. 

what (I think) we can do is to make sure that if the Market Place page is opened in a new window - we will make sure that it has a scroll bar and the URL box.

Comment 4 Matt Reid 2014-06-30 15:34:51 UTC
Created attachment 913465 [details]
My Firefox Settings

FF's "Open new windows in a new tab instead" is enabled. I haven't changed any settings around stuff like that from the FF defaults.

I don't think my coworker changed any settings around that on their FF install either, and they're on a different platform. I think the behavior that RHEV is exhibiting is for standard settings that most people will have on FF, but I could be wrong.

Comment 5 Einav Cohen 2014-07-02 21:30:49 UTC
(In reply to Matt Reid from comment #4)
> Created attachment 913465 [details]
> My Firefox Settings
> 
> FF's "Open new windows in a new tab instead" is enabled. I haven't changed
> any settings around stuff like that from the FF defaults.
> 
> I don't think my coworker changed any settings around that on their FF
> install either, and they're on a different platform. I think the behavior
> that RHEV is exhibiting is for standard settings that most people will have
> on FF, but I could be wrong.

can you please verify that? we are not forcibly opening URLs in new windows, we are relying on the browser's behavior for that.

Comment 6 Matt Reid 2014-07-03 14:32:54 UTC
Just verified that the behavior is the same on their Mac with FF 29 and rhevm-3.3.0-0.45.el6ev. Their tab settings are the same as mine, which are the FF defaults. Works and looks like the video I attached earlier.

Chrome opens a normal tab to the marketplace for both of us, which works as you would expect.

Comment 7 Alexander Wels 2014-07-07 20:11:52 UTC
@Matt,

Does opening the 'guide' open a new tab or new window?

Comment 8 Alexander Wels 2014-07-08 13:08:58 UTC
I just double checked and for me it opens in a new window as well. Basically this is because the browser considers these 'popups' and not new windows. Each browser handles them differently and FF made the decision to not do popups in tabs, but open a new window.

Comment 9 Matt Reid 2014-07-08 13:29:37 UTC
For what it's worth, I updated my system last night, and now with FF 30, the Marketplace opens in a new tab, and things seem to work properly.

Comment 10 Einav Cohen 2014-09-10 16:17:43 UTC
I see that this was backported to ovirt-engine-3.5, even though this BZ is flagged for 3.6, therefore re-flagging for 3.5.

Comment 11 Petr Kubica 2014-09-11 11:24:29 UTC
Verified in 3.5.0-0.10.master.el6ev


Note You need to log in before you can comment on or make changes to this bug.