Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1106918 - Confusing coloring of buttons in Hypervisor
Summary: Confusing coloring of buttons in Hypervisor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2014-06-09 18:26 UTC by Matt Reid
Modified: 2016-02-10 20:07 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:59:01 UTC
oVirt Team: Node


Attachments (Terms of Use)
Ready to Reboot, it's isn't red anymore (deleted)
2014-06-09 18:27 UTC, Matt Reid
no flags Details
Reboot is red, indicating that you can't select it (deleted)
2014-06-09 18:28 UTC, Matt Reid
no flags Details
Gray buttons in RHEVH (deleted)
2014-06-09 18:28 UTC, Matt Reid
no flags Details
Another screen showing gray buttons (deleted)
2014-06-09 18:29 UTC, Matt Reid
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 33015 master MERGED ui: Adjust colors Never

Description Matt Reid 2014-06-09 18:26:22 UTC
Description of problem:
I'm not sure if this is what RHEV always looks like, or if it's a version specific thing or a function of the Lenovo laptop I'm looking at RHEVH on, but the normal coloring of selectable buttons in the Hypervisor UI is gray, while disabled things are red. Normal text is black.

I loaded RHEVH onto a vm on my system, but both versions that I've installed (which are different from what I have on the other system), show the selectable things using black, instead of gray. 

What color are selectable links/buttons supposed to be? Gray or black? Why are disabled things shown as red?

Normal UI conventions have disabled things as gray. 


Version-Release number of selected component (if applicable):
These I've tried in a vm and the buttons were black
rhev-hypervisor6-6.5-20140121.0
rhevh-6.5-20131111.0.0

This one I'm running on physical hardware and it shows gray buttons, rather than black (I'm not sure where I can get this version off of our servers without setting up a RHEL vm to build a usb installer from again, I wiped the drive and system I initially used)
RHEV-H 6.5-20140520.0

How reproducible:
100%

Steps to Reproduce:
The quickest way to see this is to install RHEVH
1. Start installation process
2. As RHEV-H installs, you see < Reboot > shown in red text
3. When it finishes, the red text changes to gray, or black, in some cases, and then you can reboot the system

Actual results:
Buttons sometimes are red, until they turn either black or gray and let you interact with them. Red is typically an error color, having a Close button light up Red is worrisome to me, I wasn't initially sure why it was that color and had to figure it out.

Expected results:
Buttons that you can't interact with to look disabled, and be gray. Selectable items to look interactive, and be black or indicated somehow that they're not plain text. 

Additional info:

Comment 1 Matt Reid 2014-06-09 18:27:34 UTC
Created attachment 905609 [details]
Ready to Reboot, it's isn't red anymore

Comment 2 Matt Reid 2014-06-09 18:28:19 UTC
Created attachment 905610 [details]
Reboot is red, indicating that you can't select it

Comment 3 Matt Reid 2014-06-09 18:28:49 UTC
Created attachment 905612 [details]
Gray buttons in RHEVH

Comment 4 Matt Reid 2014-06-09 18:29:16 UTC
Created attachment 905613 [details]
Another screen showing gray buttons

Comment 6 Yaning Wang 2014-12-11 09:07:41 UTC
Tested on

RHVH-H 6.6-20141119.0.el6ev
ovirt-node-3.1.0-0.27.el6


Test steps:

1. Start installation process
2. As RHEV-H installs, you see < Reboot > shown in gray text and in disabled state
3. When it finishes, change to black and in enabled state

Comment 8 errata-xmlrpc 2015-02-11 20:59:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.