Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1105691 - Quick Start Guide has out of date subscription information listed
Summary: Quick Start Guide has out of date subscription information listed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Tahlia Richardson
QA Contact: Julie
URL:
Whiteboard:
Depends On:
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2014-06-06 18:29 UTC by Matt Reid
Modified: 2014-09-19 01:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1132792 (view as bug list)
Environment:
Last Closed: 2014-09-19 01:32:35 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Matt Reid 2014-06-06 18:29:57 UTC
Description of problem:
The Quick Start Guide doesn't include any information about how to use subscription manager, and references the RHN Classic channels you need access to, vs which subscriptions you need to attach and which repositories you need to enable. The information in the Installation Guide is much more up to date. It'd be nice to pull that information over from the Install guide and maybe chop it down a little bit to make it more brief.

Version-Release number of selected component (if applicable):
current

Additional info:

Comment 1 Jodi Biddle 2014-07-14 15:03:00 UTC
Hi Matt

We extensively re-structured the installation guides for 3.4 - can you please advise if the most recent subscription content is better? 

https://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html-single/Installation_Guide/index.html#Subscribing_to_the_Red_Hat_Enterprise_Virtualization_Manager_Channels_using_RHN_Classic

Comment 2 Matt Reid 2014-07-15 18:25:31 UTC
Section 2.3.1. Subscribing to the Red Hat Enterprise Virtualization Manager Channels using Subscription Manager looks good. It covers registration, searching for a subscription, attaching a subscription, and then ensuring the necessary repositories are enabled.


In section 2.4.1. Configuring an Offline Repository for Red Hat Enterprise Virtualization Manager Installation, on step 3:

"3. Add required channel subscriptions
Subscribe the system for all channels listed in the Red Hat Enterprise Virtualization - Installation Guide.

   A. Subscription Manager
   B. RHN Classic"

It seems like instead of telling me to look in the guide I'm currently looking in, perhaps we should either list out the 4 lines needed to ensure the channels/repositories are enabled, or reference the earlier sections that detail the entire process, and link up to them. In a doc that's 200 pages, I don't think saving the few lines is worth obscuring important information and hoping that customers can go off and find the relevant information in the doc on their own. The information they need is in 2.3.1. and 2.3.2, we should mention that here.

Step 1:
"1. Install Red Hat Enterprise Linux
Install Red Hat Enterprise Linux 6 Server on a system that has access to Red Hat Network. This system downloads all required packages, and distribute them to your offline system(s)."

has a minor typo: "This system downloads all required packages, and distribute[s] them..."


The problem is much more widespread than just here, but I've noticed that our docs across different products use different terminology when describing the registration & subscription steps using Subscription Management, hopefully at some point down the road we can figure out how to bring those into closer alignment...

I only looked at the sections that seemed relevant to subscriptions, but the information there looks solid, and I think covers the basics. One additional thing we might want to consider having is showing how to do the process through subscription-manager-gui, for people who would prefer to use the Subscription Manager UI, rather than a terminal.

Comment 3 Matt Reid 2014-07-15 18:36:29 UTC
As this BZ was against the Quick Start guide, and I don't see one for 3.4, has that been dropped? or is that coming later?

Comment 4 Jodi Biddle 2014-07-15 23:34:52 UTC
We merged the evaluation, quick start and installation guides as trying to decide which one to use was confusing, and common content had diverged too much which isn't helpful to customers either. The Install guide now has a quick start chapter instead.

Comment 7 Tahlia Richardson 2014-08-21 06:08:59 UTC
Added channels to topic [9420]

Comment 8 Tahlia Richardson 2014-08-22 05:09:56 UTC
Awaiting rebuild for fixes. 

Cloning for addition of subscription manager gui procedure.

Comment 9 Tahlia Richardson 2014-08-29 06:54:32 UTC
Documentation Link 
------------------------------

https://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5-Beta/html-single/Installation_Guide/index.html#Configuring_an_Offline_Repository_for_Red_Hat_Enterprise_Virtualization_Manager_Installation


What Changed 
------------------------------

Configuring an Offline Repository for Red Hat Enterprise Virtualization Manager Installation [9420-700931]

Fixed a typo (s/distribute/distributes) in step 1, and added the required channels to step 3.

Updated revision history: [34615-704248]


NVR
------------------------------

Red_Hat_Enterprise_Virtualization-Installation_Guide-3.5-Beta-web-en-US-3.5-9.el6eng

Comment 10 Julie 2014-09-05 03:50:12 UTC
Removed RHN classic content as instructed by the content strategist team.
Everything else in comment9 is verified.

Cheers,
Julie


Note You need to log in before you can comment on or make changes to this bug.