Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1105296 - RHN Registration Profile Name has odd string requirements
Summary: RHN Registration Profile Name has odd string requirements
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1
Blocks: RHEV-RHCI 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-05 19:39 UTC by Matt Reid
Modified: 2016-02-10 20:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:58:54 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 30661 master MERGED rhn_page: do not limit profile name length Never

Description Matt Reid 2014-06-05 19:39:12 UTC
Description of problem:
In RHEV-H, when I go to the RHN Registration screen, I can optionally enter a Profile Name. 

Starting to type in the field, I see a red error message pop in underneath the field, shifting the UI, telling me that "The field must contain an empty string or anything (min. 3 chars)."

Is it really necessary to have such an arbitrary enforcement for an optional string? Especially when typing anything in that field will trigger the error, since there's no message when it's empty, but as you put the first few characters in there, it shows up, only to disappear if you type a few more. 

I don't recall ever seeing such a length requirement enforced in Portal or through Subscription Manager. If they want to name it something with only a few characters and that works for them, why should we deny them from doing that?

Version-Release number of selected component (if applicable):
6-5.20140520.0

How reproducible:
100%

Steps to Reproduce:
1. log into RHEV-H
2. go down to the RHN Registration screen (assuming you have networking set up)
3. start naming your system with a profile name

Actual results:
UI shifts as I start typing and I see an error message, when I'm not even done typing. I could be planning on typing a string longer than 2 characters, so why show it before they've even shifted focus from the field?

Expected results:
No weird length requirement for the profile name string, or at least not to get yelled at with an error message when I'm in the act of typing and will probably enter something that doesn't warrant showing the error.

Additional info:

Comment 2 Yaning Wang 2014-12-18 06:22:22 UTC
Tested on:

RHEV-H 6.6-20141212.0.el6ev
ovirt-node-3.1.0-0.34.el6


Test steps:

1. clean install rhevh
2. goto "RHN Registration" page
3. enter user/pass/profile-name for RHN registration


Actual results:

No length requirement for the profile name warning message pops up anymore.

Comment 4 errata-xmlrpc 2015-02-11 20:58:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.