Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1105249 - Need warning message, that appear when you run hosted-engine --deploy via ssh without terminal mode
Summary: Need warning message, that appear when you run hosted-engine --deploy via ssh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Artyom
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-05 16:49 UTC by Artyom
Modified: 2015-02-11 20:40 UTC (History)
6 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.0-0.2.master.el6_5
Doc Type: Bug Fix
Doc Text:
Deployment of the hosted engine via ssh without terminal mode fails when establishing the storage connection. Attempting to deploy the hosted engine in this way now fails with a warning that it should be executed with terminal mode.
Clone Of:
Environment:
Last Closed: 2015-02-11 20:40:03 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC
oVirt gerrit 31698 master MERGED packaging: setup: require tty over ssh Never
oVirt gerrit 31699 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: require tty over ssh Never

Description Artyom 2014-06-05 16:49:32 UTC
Description of problem:
Need warning message in beginning of deployment process, that appear when you run hosted-engine --deploy via ssh without terminal mode.
Because when you run 'ssh -lroot hostname "hosted-engine --deploy"' without -t parameter, you receive error on stage when need to specify path to storage: Cannot access storage connection 10.35.160.108:/RHEV/artyom_hosted_engine: permission settings on the specified storage do not allow access to the storage to vdsm user and kvm group. Verify permission settings on the specified storage or specify another location
That can confuse user

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.1.2-5.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run ssh -lroot hostname "hosted-engine --deploy"'
2. Continue deployment until stage, where you need to specify path to storage
3.

Actual results:
Error that can confuse user

Expected results:
Some error in the beginning of deployment process, that user run command via ssh without interactive mode.

Additional info:

Comment 1 Artyom 2014-12-23 12:32:52 UTC
Verified on ovirt-hosted-engine-setup-1.2.1-8.el6ev.noarch

Comment 3 errata-xmlrpc 2015-02-11 20:40:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.