Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1104512 - after upgrade from 5.5.0 to 5.6.0 few packages are left orphaned
Summary: after upgrade from 5.5.0 to 5.6.0 few packages are left orphaned
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-06-04 07:45 UTC by Jan Hutař
Modified: 2018-04-09 11:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 11:16:59 UTC


Attachments (Terms of Use)

Description Jan Hutař 2014-06-04 07:45:02 UTC
Description of problem:
After upgrade from 5.5.0 to 5.6.0 few packages are left orphaned (i.e. they were installed as part of Satellite 5.5.0, but are not present (or their updates) in 5.6.0 channels). This shows these packages are:

1. not required in 5.6.0 installation
2. we lost track about them so potential security fix do not get into
   5.6.0 installation


Version-Release number of selected component (if applicable):
rhn-upgrade-5.6.0.42-1.el*sat


How reproducible:
always


Steps to Reproduce:
1. Upgrade Satellite 5.5.0 to 5.6.0
2. Make sure you have 5.6.0 channel and not 5.5.0
3. You should not have extra packages (packages not in any subscribed channel)


Actual results:
# yum list extras
[...]
Extra Packages
freemarker.noarch     2.3.16-2.ep5.el6     @/freemarker-2.3.16-2.ep5.el6.noarch 
hivemind.noarch       1.1.1-4.1.ep5.el6    @/hivemind-1.1.1-4.1.ep5.el6.noarch  
jakarta-commons-el.noarch
                      1.0-19.2.1.1.ep5.el6 @redhat-rhn-satellite-5.5-server-x86_64-6
jaxen.noarch          1.1.2-8.ep5.el6      @/jaxen-1.1.2-8.ep5.el6.noarch       
jython.x86_64         2.2.1-4.8.el6        @/jython-2.2.1-4.8.el6.x86_64        
rhn-upgrade.noarch    5.6.0.42-1.el6sat    @redhat-rhn-satellite-5.5-server-x86_64-6
saxpath.noarch        1.0-1.3.el6sat       @/saxpath-1.0-1.3.el6sat.noarch      
servletapi4.noarch    4.0.4-6.2.1.3.ep5.el6
                                           @/servletapi4-4.0.4-6.2.1.3.ep5.el6.noarch
struts-tiles.noarch   1.3.10-1.6.ep5.el6   @redhat-rhn-satellite-5.5-server-x86_64-6
tomcat5-servlet-2.4-api.noarch
                      5.5.33-4_patch_01.ep5.el6
                                           @/tomcat5-servlet-2.4-api-5.5.33-4_patch_01.ep5.el6.noarch
velocity-dvsl.noarch  0.45-3.ep5.el6       @/velocity-dvsl-0.45-3.ep5.el6.noarch
velocity-jboss.noarch 1.4-3.ep5.el6        @/velocity-jboss-1.4-3.ep5.el6.noarch
velocity-tools.noarch 1.4-2.1.ep5.el6      @/velocity-tools-1.4-2.1.ep5.el6.noarch


Expected results:
That listing should be empty.

Comment 1 Tomas Lestach 2018-04-09 11:16:59 UTC
We have re-reviewed this bug, as part of an ongoing effort to improve Satellite/Proxy feature and bug updates, review and backlog.

This is a low priority bug and has no currently open customer cases. While this bug may still valid, we do not see it being implemented prior to the EOL of the Satellite 5.x product. As such, this is being CLOSED DEFERRED. 

Closing now to help set customer expectations as early as possible. You are welcome to re-open this bug if needed.


Note You need to log in before you can comment on or make changes to this bug.