Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1103133 - [ovirt-guest-agent] applications_list variable doesn't contain rhevm-guest-agent-* but ovirt-guest-agent-*
Summary: [ovirt-guest-agent] applications_list variable doesn't contain rhevm-guest-ag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Jiri Belka
URL:
Whiteboard: virt
Depends On:
Blocks: 1110699 1110828 1110829 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-30 11:04 UTC by Jiri Belka
Modified: 2015-02-11 17:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the application_list entry in the ovirt-guest-agent.conf file contained references to 'ovirt-guest-agent' in the commented out sections. If those would have been uncommented the values would have been overriding the default configuration and no rhevm-guest-agent package would have been reported. With this update, 'ovirt-guest-agent' has been changed to 'rhevm-guest-agent' so that if the section was uncommented, it would be a proper override.
Clone Of:
: 1110699 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:40:51 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0206 normal SHIPPED_LIVE ovirt-guest-agent bug fix and enhancement update 2015-02-11 22:33:33 UTC

Description Jiri Belka 2014-05-30 11:04:25 UTC
Description of problem:

# grep applications_list /etc/ovirt-guest-agent.conf 
#applications_list = kernel ovirt-guest-agent ovirt-guest-agent-common xorg-x11-drv-qxl linux-image xserver-xorg-video-qxl xf86-video-qxl kernel-desktop kernel-default kernel-trace kernel-vanilla kernel-debug kernel-ec2 kernel-xen

see 'ovirt' instead of 'rhevm' above. If anybody uncomments this line to modify values, 'rhevm-guest-agent-common' won't be send to engine and thus SSO would not work.

Version-Release number of selected component (if applicable):
rhevm-guest-agent-common-1.0.9-4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. grep applications_list /etc/ovirt-guest-agent.conf
2.
3.

Actual results:
ovirt insteam of rhevm

Expected results:
rhevm-guest-*

Additional info:
depending of reported 'rhevm-guest-agent*' info for SSO was removed upstream according to vfeenstr@

Comment 3 Jiri Belka 2014-08-01 13:13:20 UTC
ok, rhevm-guest-agent-common.noarch 0:1.0.10-1.el6_5

Comment 4 Julie 2015-01-27 00:16:19 UTC
Hi Vinzenz, 
    Thanks for your doc text. Just want to check if the fix is that 'ovirt-guest-agent' is no longer in the config file and is longer available for uncommenting?

Cheers,
Julie

Comment 5 Vinzenz Feenstra [evilissimo] 2015-01-27 08:53:02 UTC
It was changed in the config file to 'rhevm-guest-agent' so that if uncommented it would be the proper override.

Comment 7 errata-xmlrpc 2015-02-11 17:40:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0206.html


Note You need to log in before you can comment on or make changes to this bug.