Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 110295 - Can't install beta free conexant hcf modem driver
Summary: Can't install beta free conexant hcf modem driver
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-18 00:29 UTC by Slobodan Sredojevic
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:03 UTC


Attachments (Terms of Use)

Description Slobodan Sredojevic 2003-11-18 00:29:59 UTC
Hello people,

Consider this as a half of a normal bug report cause I am reporting
problems related with beta
propriatery drivers and win modem device. However, hope this problem
will be solved in next release cause
there are many people using those hcf and hsf modems at least in their
laptops altough they are poor quality
both modems and drivers. Paid versions are available somewhere on
http://www.linuxant.com.

Download those beta drivers here:
http://gentoo.inode.at/distfiles/hcfpcimodem-0.99lnxtbeta03042700.tar.gz
then unpack, cd , make install and call /usr/sbin/hcfpciconfig

Module compilation fails. Log message is: (Seems there is problem with
kernel cause I successfully installed
it under vanilla 2.4.22 sources under fedora core 1 later and it works
well).

rm -f *.o *.a
make[1]: Entering directory `/usr/lib/hcfpci/modules/osspec'
rm -f *.o *.a
make[1]: Leaving directory `/usr/lib/hcfpci/modules/osspec'
* compiling (gcc) mod_osspec.c
make -C osspec all
make[1]: Entering directory `/usr/lib/hcfpci/modules/osspec'
* compiling (gcc) osstdio.c
* compiling (gcc) osnvm.c
* compiling (gcc) osresour.c
* compiling (gcc) osservices.c
* compiling (gcc) osstring.c
ar cr libosspec.a osstdio.o osnvm.o osresour.o osservices.o osstring.o
make[1]: Leaving directory `/usr/lib/hcfpci/modules/osspec'
> linking kernel module hcfpciosspec.o
                                                                     
                                                       
* compiling (gcc) mod_engine.c
> linking kernel module hcfpciengine.o
                                                                     
                                                       
* compiling (gcc) serial_hcf.c
In file included from serial_hcf.c:943:
serial_core.c: In function `uart_close':
serial_core.c:1073: invalid operands to binary ==
make: *** [serial_hcf.o] Error 1

---
btw. great work in fedora!
Cheers, Slobodan Sredojevic

Comment 1 Arjan van de Ven 2003-11-18 08:15:22 UTC

*** This bug has been marked as a duplicate of 78616 ***

Comment 2 Michael Young 2003-11-18 16:38:03 UTC
The answer is on one of the linuxant mailing lists, see
http://www.linuxant.com/pipermail/hsflinux/2003q3/001069.html

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.