Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1102810 - [REST API] part of users failed connect to VMs under load - Failed authenticating user
Summary: [REST API] part of users failed connect to VMs under load - Failed authentica...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Yair Zaslavsky
QA Contact: Yuri Obshansky
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-29 15:09 UTC by Yuri Obshansky
Modified: 2016-02-10 19:32 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 03:13:57 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Juan Hernández 2014-06-03 14:28:13 UTC
Not sure why the authentication is failing, but in addition to that failure we also have a clear NPE in the ProvisionalAuthenticationResult class: we should check if "userAuthResult" is not null before using it.

Yair, can you take a look?

Comment 2 Yair Zaslavsky 2014-06-04 04:04:16 UTC
Well, not sure about why the specific user failed here - looks like a communication issue to the IPA server. I will need some more info on that.
For example I don't remember if the IPA server is a physical machine or on a VM.
Regarding the NPE-  should deifnitely be fixed.

Comment 4 Oved Ourfali 2014-09-01 09:29:57 UTC
Yair - please fix the NPE.

Comment 5 Yair Zaslavsky 2014-09-02 03:13:57 UTC
Does not reproduce at 3.5, if relevant, please clone to 3.4


Note You need to log in before you can comment on or make changes to this bug.