Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1102772 - Missing link in usage_message
Summary: Missing link in usage_message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Petr Kubica
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-29 14:12 UTC by Petr Beňas
Modified: 2016-02-10 19:16 UTC (History)
9 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:15:03 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30018 master MERGED restapi: Fix prefix in RSDL Never
oVirt gerrit 30091 ovirt-engine-3.5 MERGED restapi: Fix prefix in RSDL Never
oVirt gerrit 30257 master MERGED restapi: Remove leading / from RSDL action names Never
oVirt gerrit 30258 ovirt-engine-3.5 MERGED restapi: Remove leading / from RSDL action names Never
oVirt gerrit 31526 ovirt-engine-3.5 MERGED restapi: Remove trailing slashes from RSDL prefix Never

Description Petr Beňas 2014-05-29 14:12:53 UTC
Description of problem:
<usage_message>
<message>
Request syntactically incorrect. See the link description below for the correct usage:
</message>
</usage_message>

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140519181229.gitc6324d4.el6.noarch

How reproducible:


Steps to Reproduce:
1. post empty or incorrect string to /api/templates
2.
3.

Actual results:
no 'link description bellow'

Expected results:
message showing expected syntax

Additional info:

Comment 1 Juan Hernández 2014-06-03 13:52:46 UTC
I can't reproduce this posting empty or incorrect strings, for example:

#!/bin/sh -x

url="https://fedora.example.com/ovirt-engine/api"
user="admin@internal"
password="******"

curl \
--insecure \
--request POST \
--header "Accept: application/xml" \
--header "Content-Type: application/xml" \
--user "${user}:${password}" \
--data "" \
${url}/templates

This produces the correct link description. Can you provide an script similar to the above one that reproduces the issue?

Comment 2 Juan Hernández 2014-06-03 15:07:50 UTC
After checking with Petr I see that the issue reproduces when using the /api URL instead of /ovirt-engine/api.

Comment 3 Petr Beňas 2014-06-16 11:26:15 UTC
The requested informationi was clarified in an IRC chat, clearing the needinfo.

Comment 4 Petr Beňas 2014-07-29 08:56:46 UTC
Still reproducible in beta2 (3.5.0-0.0.master.20140722232058.git8e1babc.el6) with both /api and /ovirt-engine/api.

Comment 6 Petr Kubica 2014-09-10 10:45:41 UTC
Verified in 3.5.0-0.10.master.el6ev

Comment 8 Eyal Edri 2015-02-17 17:15:03 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.