Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1102646 - Can't configure vNIC QoS to "unlimited" once it had been set
Summary: Can't configure vNIC QoS to "unlimited" once it had been set
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: Meni Yakove
URL:
Whiteboard: network
Depends On: 1077684
Blocks: 1105080 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-29 11:27 UTC by Nir Yechiel
Modified: 2016-02-10 19:53 UTC (History)
9 users (show)

Fixed In Version: vt1.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1077684
: 1105080 (view as bug list)
Environment:
Last Closed: 2015-02-17 17:07:22 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25950 None None None Never
oVirt gerrit 26736 None None None Never
oVirt gerrit 28255 None None None Never

Description Nir Yechiel 2014-05-29 11:27:39 UTC
+++ This bug was initially created as a clone of Bug #1077684 +++

Description of problem:

After setting the QoS of a vNIC, then changing it to "unlimited" (say by choosing another profile), the previous QoS values are retained.


Version-Release number of selected component (if applicable):

oVirt 3.4 (probably been around since 3.3).


How reproducible:

Always.


Steps to Reproduce:
1. Create profile with inbound and outbound bandwidth capping, assign this profile to a vNIC.
2. Create another profile without bandwidth capping, edit the vNIC and assign it this new profile.
3. Run "virsh dumpxml" on the VM.

Actual results:

the QoS limitations of the first profile are still there.


Expected results:

No bandwidth member for the vNIC should appear.


Additional info:

--- Additional comment from Antoni Segura Puimedon on 2014-03-20 09:00:24 EDT ---

vdsm expects to receive an empty dictionary to clear out the inbound or outbound settings, if nothing is received it keeps the current settings of the vNIC.

--- Additional comment from Sandro Bonazzola on 2014-05-08 09:38:44 EDT ---

This is an automated message

oVirt 3.4.1 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.

Comment 2 Meni Yakove 2014-07-17 07:01:41 UTC
ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch
vdsm-4.16.0-27.git00146ed.el6.x86_64

Comment 3 Eyal Edri 2015-02-17 17:07:22 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.