Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1102521 - pulp_auth under hammer ping cmd throwing undefined method error
Summary: pulp_auth under hammer ping cmd throwing undefined method error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1056323 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-29 06:39 UTC by Sachin Ghai
Modified: 2016-04-22 15:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:27:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
production.log (deleted)
2014-05-29 06:39 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6211 None None None 2016-04-22 15:50:11 UTC

Description Sachin Ghai 2014-05-29 06:39:30 UTC
Created attachment 900254 [details]
production.log

Description of problem:
Installed new sat6 snap7 compose2 (Satellite/Satellite-6.0.3-RHEL-6-20140528.4)
After installation, I got error reported in bz:#1099933.

But when I checked the status with hammer ping command, found pulp-auth is throwing undefined method error:

[root@dhcp201-185 ~]# hammer ping
candlepin:      
    Status:          ok
    Server Response: Duration: 96ms
candlepin_auth: 
    Status:          ok
    Server Response: Duration: 32ms
pulp:           
    Status:          ok
    Server Response: Duration: 268ms
pulp_auth:      
    Status:          FAIL
    Server Response: Message: undefined method `resources' for nil:NilClass
elasticsearch:  
    Status:          ok
    Server Response: Duration: 88ms
katello_jobs:   
    Status:          ok
    Server Response: Duration: 30ms

Version-Release number of selected component (if applicable):
sat6 snap7 compose2 (Satellite/Satellite-6.0.3-RHEL-6-20140528.4)



How reproducible:
always

Steps to Reproduce:
1. install new build as pointed above
2. run hammer ping cmd after katello-installer
3.

Actual results:
pulp_auth:      
    Status:          FAIL
    Server Response: Message: undefined method `resources' for nil:NilClass

Expected results:
Status for All services should be 'ok'

Additional info:

Comment 1 RHEL Product and Program Management 2014-05-29 06:55:38 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2014-06-04 03:10:27 UTC
*** Bug 1056323 has been marked as a duplicate of this bug. ***

Comment 4 Partha Aji 2014-06-13 13:11:00 UTC
Created redmine issue http://projects.theforeman.org/issues/6211 from this bug

Comment 5 Bryan Kearney 2014-06-17 12:03:52 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6211 has been closed

Comment 6 David Davis 2014-06-17 13:08:57 UTC
https://github.com/Katello/katello/pull/4265

4e31fda91c136d2754bb8f5256507ae348d49576

Fixes #6211,BZ1102521 - Requiring a user to ping pulp_auth
It looks like the code didn't properly set User.current so Katello.pulp_server
was nil. This code checks for a user in the controller. Also, it handles the
case of no user by skipping the pulp_auth check which needs remote_id from a
user.

Comment 8 sthirugn@redhat.com 2014-07-30 19:11:38 UTC
Verified.

# hammer -u admin -p changeme ping
candlepin:      
    Status:          ok
    Server Response: Duration: 26ms
candlepin_auth: 
    Status:          ok
    Server Response: Duration: 39ms
pulp:           
    Status:          ok
    Server Response: Duration: 17ms
pulp_auth:      
    Status:          ok
    Server Response: Duration: 19ms
elasticsearch:  
    Status:          ok
    Server Response: Duration: 19ms
katello_jobs:   
    Status:          ok
    Server Response: Duration: 44ms

Version Tested:
Satellite-6.0.4-RHEL-6-20140730.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.34-1.el6sat.noarch
* foreman-compute-1.6.0.34-1.el6sat.noarch
* foreman-gce-1.6.0.34-1.el6sat.noarch
* foreman-libvirt-1.6.0.34-1.el6sat.noarch
* foreman-ovirt-1.6.0.34-1.el6sat.noarch
* foreman-postgresql-1.6.0.34-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.34-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 10 Bryan Kearney 2014-09-11 12:27:39 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.