Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1102462 - virt-who's configuration can't be save after reboot rhevh
Summary: virt-who's configuration can't be save after reboot rhevh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1120594
Blocks: 1118297 1120059 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-29 03:35 UTC by Liushihui
Modified: 2016-02-10 20:06 UTC (History)
16 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1120059 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:58:34 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 28330 master MERGED installer: Persist virt-who Never
Red Hat Bugzilla 1097580 None None None Never

Internal Links: 1097580

Description Liushihui 2014-05-29 03:35:41 UTC
Description of problem:
reboot rhevh system, virt-who's config file (/etc/sysconfig/virt-who) will be reset, it will result in virt-who can't send the host/guest association to SAM server

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20140513.0.el6ev

How reproducible:
Always

Steps to Reproduce:
1 register rhevh system to SAM server with TUI
2.Configure virt-who(/etc/sysconfig/virt-who) run at vdsm mode. then restart virt-who service, virt-who will send host/guest association to SAM server
# vi /etc/sysconfig/virt-who 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=1
VIRTWHO_VDSM=1
# service virt-who restart
3. Reboot rhevh system, check the virt-who config file under the /etc/sysconfig/virt-who
4. Check the virt-who log in the /var/log/rhsm/rhsm.log
5. Check the /config/files

Actual results:
1 After step3, virt-who's configuration file has been reset to default 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=0
#VIRTWHO_INTERVAL=0
#VIRTWHO_VDSM=0
2 After step4, virt-who can't send host/guest association to SAM server
3 After setp5, /etc/sysconfig/virt-who isn't exist on this file

Expected results:
1. After step3, virt-who's configuration file should be saved after reboot the system
2. After step4, After reboot system, virt-who should still send host/guest association to SAM server normally.
3. After step5, /etc/sysconfig/virt-who should exist in /config/file

Additional info:

Comment 3 Liushihui 2014-09-17 01:39:10 UTC
According to bug 1120059's comment 3, it has been fixed. Therefore, change bug status to VERIFIED.

Comment 4 Ying Cui 2014-09-26 07:08:47 UTC
(In reply to Liushihui from comment #3)
> According to bug 1120059's comment 3, it has been fixed. Therefore, change
> bug status to VERIFIED.

Shihui, you can not change this bug status to 'VERIFIED' according to 1120059 bug, this bug is on rhev 3.5, need to use el6_rhev3.5 build to verify this bug.

1120059 is rhev 3.4.z bug.

Change it back to POST because there is no el6 rhev3.5 build now.

Comment 5 Liushihui 2014-09-26 07:26:46 UTC
Ying, I'm sorry for my mistake, I will check it on el6 rhev3.5 build when it available.Thanks.

(In reply to Ying Cui from comment #4)
> (In reply to Liushihui from comment #3)
> > According to bug 1120059's comment 3, it has been fixed. Therefore, change
> > bug status to VERIFIED.
> 
> Shihui, you can not change this bug status to 'VERIFIED' according to
> 1120059 bug, this bug is on rhev 3.5, need to use el6_rhev3.5 build to
> verify this bug.
> 
> 1120059 is rhev 3.4.z bug.
> 
> Change it back to POST because there is no el6 rhev3.5 build now.

Comment 6 Yaning Wang 2014-10-15 09:42:23 UTC
Tested On:

Version-Release number of selected component (if applicable):

rhev-hypervisor7-7.0-20141006.0.el7ev


Steps to Reproduce:
1 register rhevh system to SAM server with TUI
2.Configure virt-who(/etc/sysconfig/virt-who) run at vdsm mode. then restart virt-who service, virt-who will send host/guest association to SAM server
# vi /etc/sysconfig/virt-who 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=1
VIRTWHO_VDSM=1
# service virt-who restart
3. Reboot rhevh system, check the virt-who config file under the /etc/sysconfig/virt-who
4. Check the virt-who log in the /var/log/rhsm/rhsm.log
5. Check the /config/files

Actual results:
1 virt-who's configuration file saved after reboot the system (Fixed)

2 After step4, virt-who can't send host/guest association to SAM server (Still Failed) due to https://bugzilla.redhat.com/show_bug.cgi?id=1120594

3 After setp5, /etc/sysconfig/virt-who exist in this file (Fixed) 


admonition info:

can not register rhevh system to SAM server due to bug 1120594

Comment 7 Liushihui 2014-10-24 01:42:22 UTC
Hi, Yaning

I'm sorry I think I need to clarify that virt-who can't send host/guest association to SAM server after step4, it should due to bug 1153405, bug 1120594 isn't related to this bug. 

Thanks.
Liushihui 

(In reply to Yaning Wang from comment #6)
> Tested On:
> 
> Version-Release number of selected component (if applicable):
> 
> rhev-hypervisor7-7.0-20141006.0.el7ev
> 
> 
> Steps to Reproduce:
> 1 register rhevh system to SAM server with TUI
> 2.Configure virt-who(/etc/sysconfig/virt-who) run at vdsm mode. then restart
> virt-who service, virt-who will send host/guest association to SAM server
> # vi /etc/sysconfig/virt-who 
> VIRTWHO_BACKGROUND=1
> VIRTWHO_DEBUG=1
> VIRTWHO_INTERVAL=1
> VIRTWHO_VDSM=1
> # service virt-who restart
> 3. Reboot rhevh system, check the virt-who config file under the
> /etc/sysconfig/virt-who
> 4. Check the virt-who log in the /var/log/rhsm/rhsm.log
> 5. Check the /config/files
> 
> Actual results:
> 1 virt-who's configuration file saved after reboot the system (Fixed)
> 
> 2 After step4, virt-who can't send host/guest association to SAM server
> (Still Failed) due to https://bugzilla.redhat.com/show_bug.cgi?id=1120594
> 
> 3 After setp5, /etc/sysconfig/virt-who exist in this file (Fixed) 
> 
> 
> admonition info:
> 
> can not register rhevh system to SAM server due to bug 1120594

Comment 8 Liushihui 2014-11-12 06:46:29 UTC
Verified it on rhev-hypervisor6-6.6-20141107.0 and Rhev-hypervisor7-7.0-20141107.0.el7ev

Part 1: Verify it on rhev-hypervisor6-6.6-20141107.0
Test version:
rhev-hypervisor6-6.6-20141107.0 + RHEV 3.5
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
vdsm-4.16.7.3-1.el6ev.x86_64

1.Configure virt-who(/etc/sysconfig/virt-who) run at vdsm mode.
# vi /etc/sysconfig/virt-who 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=1
VIRTWHO_VDSM=1
# service virt-who restart
2. Reboot rhevh system, check the virt-who config file under the /etc/sysconfig/virt-who
3. Check the /config/files

Test results:
1. After step2, virt-who's configuration file can be saved after reboot the system
2. After step3, /etc/sysconfig/virt-who can be persisted in /config/file

Part 2: Verify it on Rhev-hypervisor7-7.0-20141107.0.el7ev
Test version:
Rhev-hypervisor7-7.0-20141107.0.el7ev + RHEV 3.5
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
vdsm-4.16.7.3-1.el7ev.x86_64

1.Configure virt-who(/etc/sysconfig/virt-who) run at vdsm mode.
# vi /etc/sysconfig/virt-who 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=1
VIRTWHO_VDSM=1
# service virt-who restart
2. Reboot rhevh system, check the virt-who config file under the /etc/sysconfig/virt-who
3. Check the /config/files

Test results:
1. After step2, virt-who's configuration file can be saved after reboot the system
2. After step3, /etc/sysconfig/virt-who can be persisted in /config/file

According the test results on these two build, it should be verify.

Comment 10 errata-xmlrpc 2015-02-11 20:58:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.