Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1102021 - Default storage type is not Shared/local in rhevm-setup
Summary: Default storage type is not Shared/local in rhevm-setup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Petr Kubica
URL:
Whiteboard: integration
: 1063712 (view as bug list)
Depends On:
Blocks: rhev3.5beta3
TreeView+ depends on / blocked
 
Reported: 2014-05-28 11:06 UTC by Aharon Canan
Modified: 2015-02-12 14:09 UTC (History)
19 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-13
Doc Type: Bug Fix
Doc Text:
The kind of shared storage is no longer an issue, removing the question.
Clone Of:
Environment:
Last Closed: 2015-02-12 14:09:38 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screenshot (deleted)
2014-05-28 11:06 UTC, Aharon Canan
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31965 master MERGED packaging: setup: Updating default storage type question Never
oVirt gerrit 32452 ovirt-engine-3.5 MERGED packaging: setup: Updating default storage type question Never
oVirt gerrit 32709 master MERGED packaging: setup: removing default storage type question Never
oVirt gerrit 32710 ovirt-engine-3.5 MERGED packaging: setup: removing default storage type question Never
oVirt gerrit 32711 ovirt-engine-3.4 MERGED packaging: setup: removing default storage type question Never
oVirt gerrit 33932 master MERGED packaging: setup: removing 'Datacenter storage type' from the summary Never
oVirt gerrit 33934 ovirt-engine-3.5 MERGED packaging: setup: removing 'Datacenter storage type' from the summary Never
oVirt gerrit 33935 ovirt-engine-3.4 ABANDONED packaging: setup: removing 'Datacenter storage type' from the summary Never

Description Aharon Canan 2014-05-28 11:06:27 UTC
Created attachment 899942 [details]
screenshot

Description of problem:
------------------------------
Default storage type is not Shared/local in rhevm-setup
Still appear - "Default storage type: (NFS, FC, ISCSI, POSIXFS, GLUSTERFS) [NFS]:"

Version-Release number of selected component (if applicable):
av9.2

How reproducible:
-----------------------
100%

Steps to Reproduce:
----------------------------
1. run rhevm-setup
2.
3.

Actual results:
------------------
Default storage type: (NFS, FC, ISCSI, POSIXFS, GLUSTERFS) [NFS]:

Expected results:
----------------------
Shared/local 

Additional info:

Comment 1 Sandro Bonazzola 2014-06-09 06:49:30 UTC
Doesn't look like a severity urgent bug: above values are still valid on 3.5.
But I agree it should be fixed.

Comment 3 Simone Tiraboschi 2014-09-04 08:47:29 UTC
*** Bug 1063712 has been marked as a duplicate of this bug. ***

Comment 5 Simone Tiraboschi 2014-09-09 15:59:26 UTC
Reviewing it, we found that the question is superfluous since
almost all the user will choose 'shared'.

Comment 6 Sven Kieske 2014-09-09 16:10:48 UTC
(In reply to Simone Tiraboschi from comment #5)
> Reviewing it, we found that the question is superfluous since
> almost all the user will choose 'shared'.

What?

Where is your data on that case from?

What about local storage users? Will this not be supported anymore?

My company relies on this feature.

Can you please elaborate what this means?

Thanks

Comment 7 Simone Tiraboschi 2014-09-09 21:15:18 UTC
(In reply to Sven Kieske from comment #6)

> My company relies on this feature.
> Can you please elaborate what this means?

Current question is about NFS, FC, ISCSI, POSIXFS and GLUSTERFS which are indeed the different technologies we support for a shared datastore so we are already assuming that the Default storage will be a shared one. No changes here.

engine-setup is creating a local datastore only in the all-in-one installation witch creates a new local_datacenter with a new local_cluster attaching than a local_storagedomain. It's completely a different setup; by the way also in that we still have a default datacenter which is configured to be used with a shared storage domain. So no changes also there.

At the least you can still change the Default datacenter storage domain default type from the webadmin GUI.

The aim of this patch is just to avoid a superfluous question in order to make engine-setup more friendly.

Comment 8 Itamar Heim 2014-09-10 04:41:13 UTC
(In reply to Sven Kieske from comment #6)
> (In reply to Simone Tiraboschi from comment #5)
> > Reviewing it, we found that the question is superfluous since
> > almost all the user will choose 'shared'.
> 
> What?
> 
> Where is your data on that case from?
> 
> What about local storage users? Will this not be supported anymore?
> 
> My company relies on this feature.
> 
> Can you please elaborate what this means?
> 
> Thanks

Hi Sven,

'local' wasn't an option for the default data center mode during until now.
(this isn't removing the local DC type from engine, just keeping the current status of this mode not available in regular setup, since the all-in-one plugin covers this case if needed better[1])

the current question in setup was about which type of shared storage. since this is no longer an issue, we just remove this question.

can you please explain the use case in which you install today the engine with the default DC in local during setup?

thanks,
   Itamar

[1] and even the allinone plugin is considered "for poc's" by most.

Comment 9 Sven Kieske 2014-09-10 07:08:46 UTC
Thanks for the clarificaton, I thought this was about removing
the local storage option at all, sorry for the confusion.

You are completely right about removing this initial question.

Comment 10 Eyal Edri 2014-09-28 11:29:24 UTC
this bug was moved to MODIFIED before vt4 build date thus moving to ON_QA.
if you belive this bug isn't in vt4, please report to rhev-integ@redhat.com

Comment 11 Petr Kubica 2014-10-08 13:24:34 UTC
Verifed in rhevm 3.5.0-0.14.beta.el6ev


Note You need to log in before you can comment on or make changes to this bug.