Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1101954 - Impossible to confirm upgrade from answerfile
Summary: Impossible to confirm upgrade from answerfile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1105002 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-28 09:01 UTC by Petr Beňas
Modified: 2015-02-11 17:45 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When you upgrade from an older version of Red Hat Enterprise Virtualization, engine-setup now stores the answer to the question "Would you like to continue with the upgrade?" in the answer file. This makes unattended upgrades possible.
Clone Of:
: 1105002 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:45:10 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0196 normal SHIPPED_LIVE rhevm-setup-plugins bug fix and enhancement update 2015-02-11 22:35:33 UTC

Description Petr Beňas 2014-05-28 09:01:13 UTC
Description of problem:
Upgrade to 3.4 cannot be automated after https://bugzilla.redhat.com/show_bug.cgi?id=1059668 . It generates OVESETUP_RHEVM_SUPPORT/redhatSupportConfirmUpgrade, but when this option is used in an answerfile passed to the rhevm-setup, it still asks for upgrade confirmation. 

Version-Release number of selected component (if applicable):
rhevm-setup-plugins-3.4.0-2.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
          Would you like to continue with the upgrade? (Yes, No) [Yes]: yes


Expected results:
non-interactive upgrade

Additional info:

Comment 4 Petr Beňas 2014-09-09 09:04:30 UTC
in rhevm-setup-3.5.0-0.10.master.el6ev.noarch

Comment 5 Yedidyah Bar David 2014-11-04 13:33:23 UTC
Copied doc text from 3.4 clone bug 1105002, not sure it's required.

Comment 9 errata-xmlrpc 2015-02-11 17:45:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0196.html


Note You need to log in before you can comment on or make changes to this bug.