Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1101003 - Creating vm from template Menu has options that are redundant
Summary: Creating vm from template Menu has options that are redundant
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-25 10:42 UTC by Ori Gofen
Modified: 2016-05-26 01:51 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
image (deleted)
2014-05-25 10:43 UTC, Ori Gofen
no flags Details
image (deleted)
2014-05-27 16:18 UTC, Ori Gofen
no flags Details
image taken from ui,raw preallocated iscsi template (deleted)
2014-05-29 09:13 UTC, Ori Gofen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28079 master MERGED webadmin: disable format selection on thin provisioning Never

Description Ori Gofen 2014-05-25 10:42:48 UTC
Description of problem:

When Creating a vm from template with template provisioning:Thin, there is no need
to choose disks allocation policy because the engine performs image snapshot by default.

generally,this menu is very complicated and confusing.

Version-Release number of selected component (if applicable):
vdsm-4.14.7-3.el6ev.x86_64
rhevm-3.4.0-0.21.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
Setup:have dc with 2 domains(one nfs,one iscsi)
1.create vm+disk,make template
2.copy template to the other domain
3.add new vm->choose the template->advance options->Resource allocation->choose thin template provisioning

Actual results:

A user can "play" with the allocation policy window but it has no meaning(see image)

Expected results:
the disks allocation policy should be greyed out for template thin provisioning.

Additional info:

Comment 1 Ori Gofen 2014-05-25 10:43:42 UTC
Created attachment 899071 [details]
image

Comment 2 Daniel Erez 2014-05-27 15:02:58 UTC
Disk format selection should be disabled on thin provisioning.
Already fixed on: http://gerrit.ovirt.org/#/c/28079/

Comment 3 Ori Gofen 2014-05-27 16:18:43 UTC
Created attachment 899578 [details]
image

guys, there's another option which is redundant in this scenario,(view image).
choosing create as clone with provisioning policy:"thin" should be greyed out as well!

Comment 4 Daniel Erez 2014-05-28 17:51:39 UTC
(In reply to Ori from comment #3)
> Created attachment 899578 [details]
> image
> 
> guys, there's another option which is redundant in this scenario,(view
> image).
> choosing create as clone with provisioning policy:"thin" should be greyed
> out as well!

For block domains, cloning a COW disk is applicable with thin format;
hence the option is still needed. Making sure that the result format is reported correctly should be covered in bug 1101011.

Comment 5 Ori Gofen 2014-05-29 09:13:37 UTC
Created attachment 900300 [details]
image taken from ui,raw preallocated iscsi template

Hi Erez, we actually discussed that yesterday, well you are right of-course, but I don't see a reason why this option is already disabled when creating a template from raw preallocated iscsi disk(please see image), but appears when the template is on both domains (mind that the iscsi part is also raw preallocated), if COW disk is applicable with thin format,so it should be appeared on cloning menu in the case of both a template made out of raw preallocated and copied from nfs, don't you think?

Comment 6 Ori Gofen 2014-06-19 12:07:38 UTC
Verified on alpha2,see an exception to this bug at BZ #1111176

Comment 7 Allon Mureinik 2015-02-16 19:12:57 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 8 Allon Mureinik 2015-02-16 19:12:58 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.