Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1100281 - [RHEVM-SETUP] - upgrade of dwh fails using previously generated answer file
Summary: [RHEVM-SETUP] - upgrade of dwh fails using previously generated answer file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.1
Assignee: Yedidyah Bar David
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On: 1094016
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-22 12:25 UTC by rhev-integ
Modified: 2014-07-29 14:20 UTC (History)
19 users (show)

Fixed In Version: av10.1 - rhevm-dwh-3.4.1-2.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, attempting to upgrade from Red Hat Enterprise Virtualization 3.3 to Red Hat Enterprise Virtualization 3.4 using an answer file would fail under certain circumstances. This was caused by the logic used to perform upgrades in Red Hat Enterprise Virtualization 3.3, in which it was necessary for the Data Warehouse database to be installed on the same host and port as the engine database, and the Data Warehouse database did not keep the host and port in its own conf file, instead relying on that of the engine database. This would prevent setup from setting the correct database host and port, causing the upgrade process to fail. Now, this logic has been updated so that the database host and port can be correctly set using an answer file, if supplied, making it possible to perform the upgrade process under these conditions. Furthermore, users can successfully upgrade from Red Hat Enterprise Virtualization 3.3 to Red Hat Enterprise Virtualization 3.4 using an answer file by copying the database host and port from the engine conf file to the Data Warehouse conf file as follows: sed -rne 's/^ENGINE_DB_(HOST|PORT)=(.*)/DWH_DB_\1=\2/p' \ < /etc/ovirt-engine/engine.conf.d/10-setup-database.conf \ >> /etc/ovirt-engine-dwh/ovirt-engine-dwhd.conf.d/10-setup-database.conf
Clone Of: 1094016
: 1105873 (view as bug list)
Environment:
Last Closed: 2014-07-29 14:20:47 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0968 normal SHIPPED_LIVE rhevm-dwh 3.4.1 bug fix update 2014-07-29 18:18:48 UTC
oVirt gerrit 27693 master MERGED packaging: setup: use db creds from answer file Never
oVirt gerrit 28008 ovirt-engine-3.4 MERGED packaging: setup: use db creds from answer file Never
oVirt gerrit 28105 None None None Never
oVirt gerrit 29768 master MERGED packaging: setup: test only config file db password Never
oVirt gerrit 29856 ovirt-engine-dwh-3.4 MERGED packaging: setup: test only config file db password Never

Comment 1 Yedidyah Bar David 2014-06-02 08:48:52 UTC
I now verified a workaround:

3.3 engine/dwh setup
add 3.4 repo
yum update rhevm-setup
yum install rhevm-dwh-setup
engine-setup
Reply 'Cancel' at 'Please confirm installation settings'
Note name of answer file generated
engine-setup --config-append=answer-file-from-previous-run

This fails with 3.4.0.

To fix, run this command, to copy engine db host/port to dwh:

sed -rne 's/^ENGINE_DB_(HOST|PORT)=(.*)/DWH_DB_\1=\2/p' \
    < /etc/ovirt-engine/engine.conf.d/10-setup-database.conf \
    >> /etc/ovirt-engine-dwh/ovirt-engine-dwhd.conf.d/10-setup-database.conf

now engine-setup with the answer file should not fail.

Comment 5 Arthur Berezin 2014-06-08 12:30:47 UTC
Jodi, would you like to chime in for the process?

Comment 6 Yedidyah Bar David 2014-06-08 12:37:34 UTC
Jodi - note that the doc text is currently phrased for 3.4.1. I lightly adapted it to 3.4.0 in bug #1105873 but understood that another bug is not needed. You might base the release notes text on the doc text there.

Comment 7 Jodi Biddle 2014-06-09 22:24:54 UTC
Hi Didi 

We've missed the cut off for 3.4.0 inclusions for release notes, so this will be included in 3.4.1.

Comment 9 Yedidyah Bar David 2014-07-09 13:24:17 UTC
Current fix breaks unattended clean setup.

Comment 11 Jiri Belka 2014-07-15 15:03:49 UTC
is that ok that "first try" (see below) asks for confirmation? otherwise upgrade with answer file is OK.

3.3.x engine/dwh/reports 
yum update rhevm-setup # update to 3.4
service ovirt-engine-dwhd stop
engine-setup
<snapshot>

- first try:

yum install rhevm-dwh-setup rhevm-reports-setup
engine-setup --config-append=$file # asks for confirmation for packages
...
[ INFO  ] Checking for product updates...
          Setup has found updates for some packages, do you wish to update them now? (Yes, No) [Yes]: Yes

- 2nd try:

yum install rhevm-dwh-setup rhevm-reports-setup
engine-setup --config-append=$file # all automatic

Comment 12 Yedidyah Bar David 2014-07-16 20:32:40 UTC
(In reply to Jiri Belka from comment #11)
> is that ok that "first try" (see below) asks for confirmation? otherwise
> upgrade with answer file is OK.
> 
> 3.3.x engine/dwh/reports 
> yum update rhevm-setup # update to 3.4
> service ovirt-engine-dwhd stop
> engine-setup
> <snapshot>
> 
> - first try:
> 
> yum install rhevm-dwh-setup rhevm-reports-setup
> engine-setup --config-append=$file # asks for confirmation for packages
> ...
> [ INFO  ] Checking for product updates...
>           Setup has found updates for some packages, do you wish to update
> them now? (Yes, No) [Yes]: Yes
> 

How exactly was $file created?

IIRC if it was created on a system where no updates for any relevant packages were found, it will not ask about this (obviously) and not keep an answer for this question (perhaps less obvious). So using the generated answer file for a system where such updates are available will not provide an answer to this question.

In any case, this is unrelated to this bug.

> - 2nd try:
> 
> yum install rhevm-dwh-setup rhevm-reports-setup
> engine-setup --config-append=$file # all automatic

Naturally, if on second try there were no updates anymore, it does not ask about that.

Comment 13 Jiri Belka 2014-07-18 10:18:59 UTC
ok, av10.1/rhevm-dwh-3.4.1-2.el6ev

fyi, correct upgrade path of dwh/reports from 3.3 to 3.4 is:

  5.1.3. Updating Red Hat Enterprise Virtualization Manager Reports
  yum update rhevm-reports rhevm-dwh

then all was OK.

Comment 15 errata-xmlrpc 2014-07-29 14:20:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0968.html


Note You need to log in before you can comment on or make changes to this bug.