Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1099846 - Not handling VM that crashed correctly
Summary: Not handling VM that crashed correctly
Keywords:
Status: CLOSED DUPLICATE of bug 1098791
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Roy Golan
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-21 10:49 UTC by Arik
Modified: 2016-02-10 19:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 19:30:06 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Arik 2014-05-21 10:49:45 UTC
Description of problem:
VM that went down is handled by the hosts/vms monitoring twice:
1. as a VM that switched to DOWN (because it is reported as DOWN by VDSM)
2. as a VM that wasn't returned by VDSM (and running in the DB)
Obviously, #2 shouldn't happen. It is a regression that was caused by http://gerrit.ovirt.org/#/c/25547: in VdsUpdateRunTimeInfo#removeVmsFromCache we are skipping a VM if its status wasn't change instead of if it was reported as running or not.
As a result we are calling VmPoolHandler#processVmPoolOnStopVm twice and it is wrong.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. kill qemu process
2.
3.

Actual results:
VmPoolHandler#processVmPoolOnStopVm is called twice

Expected results:
VmPoolHandler#processVmPoolOnStopVm should be called one time

Additional info:
changing _vmsMovedToDown to Set or ensure we don't put the same VM more than once to it is not the right solution, we should fix the logic or change the logic (and the documentation) properly.

Comment 1 Arik 2014-08-15 19:30:06 UTC
Eventually as part of bz 1098791, I changed _vmsMovedToDown to be Set.
Working on a better solution doesn't worth the time, as the work on the refactored monitoring is already in progress.

*** This bug has been marked as a duplicate of bug 1098791 ***


Note You need to log in before you can comment on or make changes to this bug.