Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098762 - IP address of the host can't be changed to FQDN, not while host is active, neither it's under maintenance.
Summary: IP address of the host can't be changed to FQDN, not while host is active, ne...
Keywords:
Status: CLOSED DUPLICATE of bug 1060215
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: nobody nobody
QA Contact:
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-18 07:44 UTC by Nikolai Sednev
Modified: 2016-02-10 19:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-26 11:24:19 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
picture of greyed out address field. (deleted)
2014-05-18 07:45 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2014-05-18 07:44:51 UTC
Description of problem:
IP address of the host can't be changed to FQDN, not while host is active, neither it's under maintenance.

Version-Release number of selected component (if applicable):
Host:
libvirt-0.10.2-29.el6_5.7.x86_64
sanlock-2.8-1.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.415.el6_5.9.x86_64
vdsm-4.14.7-2.el6ev.x86_64
ovirt-hosted-engine-ha-1.1.2-3.el6ev.noarch

Engine:
rhevm-3.4.0-0.20.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Assemble setup containing 2 hosts and engine, give IP addresses for the hosts instead of FQDN.
2.Try changing IP address for one of the hosts to it's FQDN, while host is active, the field will be greyed out, making impossible to make any changes.
3.Same as 2, only now try to put host in to maintenance first.

Actual results:
Address can't be changed.

Expected results:
I host under maintenance, IP should be changeable to FQDN or another IP.

Additional info:
Attached picture.

Comment 1 Nikolai Sednev 2014-05-18 07:45:26 UTC
Created attachment 896752 [details]
picture of greyed out address field.

Comment 2 Oved Ourfali 2014-05-26 11:24:19 UTC
Closed as a duplicate.
The interesting use-case here is changing the host address. Not the fact that you have an IP and want to switch it to FQDN.
Using IP address is a less interesting use-case anyway, as it probably won't be used in standard environments.

*** This bug has been marked as a duplicate of bug 1060215 ***


Note You need to log in before you can comment on or make changes to this bug.