Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098603 - [RFE][webadmin] - GuideMe can't activate hosts
Summary: [RFE][webadmin] - GuideMe can't activate hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ravi Nori
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2014-05-16 16:05 UTC by Pavel Stehlik
Modified: 2016-03-09 20:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:45:34 UTC
oVirt Team: Infra
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 39992 master MERGED webadmin: GuideMe can't activate hosts Never

Description Pavel Stehlik 2014-05-16 16:05:39 UTC
Description of problem:
 This request comes from general usability team http://etherpad.corp.redhat.com/uxd-rhci-bugs-to-file 
line ~270
 We need to exit the Guide Me dialog to activate the host to the Data Center. The next step is to go back to the tab and dialog that we just left.

Proposal: add check-box (or button) for activation directly from GuideMe dialog (selecting hosts).

Version-Release number of selected component (if applicable):
av9.1

How reproducible:
100%

Steps to Reproduce:
1. have 2 clusters & host in maintenance
2. go to Datacenters tab & click GuideMe button
3. create new DC & try to select host which is in maintenance

Actual results:


Expected results:


Additional info:

Comment 1 Einav Cohen 2014-05-19 17:58:04 UTC
ideally, we should do the following:

add a "activate Hosts" check-box in the 'Select Hosts' dialog (checked by default) and simply activate the Hosts in addition to adding them to the relevant Cluster/DC. 

once clicking "OK" in the "activate Hosts" dialog, the dialog is displayed with a "loading/processing" spinner animation for 5 seconds, and then:
[if (at least) one of the selected Hosts is Up] - the 'Guide Me' dialog re-appears with the relevant following actions (buttons) available (enabled), e.g. 'Configure Storage".
[if none of the selected Hosts is Up] - the 'Guide Me' dialog re-appears, but with a pop-up that says something like "activating the Hosts may take a while, please close the 'Guide Me' window and track the Hosts activation via the Events tab or the Hosts tab". 

If the above cannot be done, we will have to wait with this problem until a overhaul improvement for the Guide Me mechanism will be designed

Comment 2 Pavol Brilla 2016-01-08 13:16:07 UTC
verified on: 3.6.2-0.1.el6 RHEVM


DC -> GuideMe - > Select host -> Select Cluster form dropdown menu & checkbox host 


Host is activated for Cluster

Comment 4 errata-xmlrpc 2016-03-09 20:45:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.