Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098580 - [rhevh] RHN registration field doesn't keep old value
Summary: [rhevh] RHN registration field doesn't keep old value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2014-05-16 15:18 UTC by Pavel Stehlik
Modified: 2016-02-10 20:09 UTC (History)
12 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:58:22 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 30541 master MERGED Populate RHN page username field Never

Description Pavel Stehlik 2014-05-16 15:18:16 UTC
Description of problem:
 RHEVH - trying to register to RHN, filling Login/pwd/profile. Once unsuccessful - and return to RHN page again, only Profile field is filled - Login/Password is wiped out.  

Version-Release number of selected component (if applicable):
RHEVH-6.5 (20140507.0.el6ev)

How reproducible:
100% (at least in case of unsucc. registration)

Steps to Reproduce:
1. go to TUI or RHEVH / RHN Registration
2. fill Login & Password & Profile Name, keep RHN, hit Save button
3. on next screen hit Close button

Actual results:


Expected results:
the information (even wrong) should stayed there

Additional info:

Comment 1 Ying Cui 2014-06-06 03:25:55 UTC
Hi Fabian,
  Do you think here should save the old/wrong values after hitting "save" on TUI?
  The similar bug on Kdump TUI: bug 957445

Thanks
Ying

Comment 2 Fabian Deutsch 2014-06-29 10:06:06 UTC
Hey Einav,

as you are the expert. What do you say: If incorrect informations were put into fields (i.e. username and password) should they be cleared or not?

Comment 3 Einav Cohen 2014-06-30 12:53:54 UTC
(In reply to Fabian Deutsch from comment #2)
> Hey Einav,
> 
> as you are the expert. What do you say: If incorrect informations were put
> into fields (i.e. username and password) should they be cleared or not?

Hi Fabian, 

I believe that the most common behavior is to keep all information in the fields, except password(s), if there are any. 
An incorrect value may be made correct only by changing/adding/removing a single character. having the user filling everything from scratch is a bad UX IMO.

[for passwords, the value is erased mostly due to security reasons, AFAIK. In addition, since password characters are usually shown as "*", the user will most likely enter it again from scratch, rather than fix the relevant character(s) so no UX problem in erasing it completely].

Comment 4 Ryan Barry 2014-07-18 15:44:02 UTC
Ok, so should we keep all fields other than password?

It looks like, at present, we pull some of the information (URL, CA URL, proxy information) directly from the RHN/SAM config files, which will not succeed if registration fails.

Keeping the username is a definite yes.
What about the rest?

Comment 5 Einav Cohen 2014-07-18 16:19:48 UTC
(In reply to Ryan Barry from comment #4)
> Ok, so should we keep all fields other than password?
> 
> It looks like, at present, we pull some of the information (URL, CA URL,
> proxy information) directly from the RHN/SAM config files, which will not
> succeed if registration fails.
> 
> Keeping the username is a definite yes.
> What about the rest?

I am not familiar with the exact RHEV-H registration process, fields involved, etc. 
The BZ reporter mentioned "Login", "Password" & "Profile Name". So all of these other than "Password" should be kept; again, the reason is that the user may need to make only a very small change to the incorrect input in order to make it correct. If there are additional non-password fields - their values should be kept as well. 
if there are fields that it makes sense to clear, e.g. fields that are supposed to be filled automatically by pulling information from RHN/SAM config files (rather than be filled manually by the user), and this information-pulling has due to a failed registration process - then obviously these fields will have to be empty.

Comment 8 wanghui 2015-01-21 05:43:58 UTC
Test Version:
rhev-hypervisor7-7.0-20150114.0
ovirt-node-3.2.1-4.el7.noarch

rhev-hypervisor6-6.6-20150114.0
ovirt-node-3.2.1-4.el6.noarch

Test step:
1. Go to TUI or RHEVH / RHN Registration
2. Fill Login & incorrect Password & Profile Name, keep RHN, hit Save button
3. On next screen hit Close button

Test result:
1. It keeps the information (even wrong) except the password in TUI.

So this issue is fixed in rhev-hypervisor6-6.6-20150114.0 and rhev-hypervisor7-7.0-20150114.0. Change the status from ON_QA to Verified.

Comment 10 errata-xmlrpc 2015-02-11 20:58:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.