Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098512 - Improve layout of NIC Details Dialog
Summary: Improve layout of NIC Details Dialog
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.6.0
Assignee: Ryan Barry
QA Contact: Meni Yakove
URL:
Whiteboard: node
: 1105724 (view as bug list)
Depends On:
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2014-05-16 12:08 UTC by Pavel Stehlik
Modified: 2016-02-10 20:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-17 15:07:23 UTC
oVirt Team: Node


Attachments (Terms of Use)
rhevh-net1.jpeg (deleted)
2014-05-16 12:08 UTC, Pavel Stehlik
no flags Details
current state vs. suggested improvement (deleted)
2014-05-19 18:21 UTC, Einav Cohen
no flags Details
UX improvement idea for NIC details (deleted)
2014-07-17 13:06 UTC, Liz
no flags Details

Description Pavel Stehlik 2014-05-16 12:08:39 UTC
Created attachment 896379 [details]
rhevh-net1.jpeg

Description of problem:
 In Network/NIC section. Current layout - see scrnsht - is quite confusing. 
IPv4:
 Please arrange/move "Netmask" between "IP address" & "Gateway".
IPv6:
 Save with "Prefix Length".  

Proposing exception as this should be easy fix which will ease confusion of users. This was raised by general usability team http://etherpad.corp.redhat.com/uxd-rhci-bugs-to-file currently line ~226.


Version-Release number of selected component (if applicable):
6.5-20140407.0.el6ev

How reproducible:
100% (ssh & console)

Steps to Reproduce:
1. Have not managed RHEVH
2. login as admin & in TUI select Network & NIC
3.

Actual results:
see scrnsht

Expected results:


Additional info:

Comment 2 Einav Cohen 2014-05-19 18:21:39 UTC
Created attachment 897271 [details]
current state vs. suggested improvement

Comment 3 Einav Cohen 2014-05-19 18:22:34 UTC
(In reply to Pavel Stehlik from comment #0)
> ...
> IPv6:
>  Save with "Prefix Length".  

I assume Pavel meant "same". 

good suggestion - see attachment 897271 [details].

Comment 4 Fabian Deutsch 2014-07-03 10:14:47 UTC
*** Bug 1105724 has been marked as a duplicate of this bug. ***

Comment 5 Fabian Deutsch 2014-07-03 10:55:40 UTC
Thanks for the UX input.

The reason why the fields were not moved there - and why it is not possible right away to do this - is that the TUI must also fit on the classic 80x24 screen.

The layout would not work on small screens if we pulled all the fields into one row.

But I am open to suggestions of how to improvfe this, but please take the 80x24 resolution into account.

Comment 6 Einav Cohen 2014-07-07 17:28:23 UTC
Fabian, why does the suggestion as appears in Comment #2/3 will not fit the classic 80x24 screen (I assume that by "80x24" you mean "1280x1024")?

Comment 7 Matt Reid 2014-07-07 17:37:11 UTC
I think he means that it has to be able to fit in the standard terminal dimensions, which are 80 characters wide by 24 lines tall.

Comment 8 Ryan Barry 2014-07-07 17:37:57 UTC
A 80 columns x 24 rows physical console (serial console, OOB KVMs, or keyboard/mouse/monitor directly attached to the RHEV-H node).

Comment 9 Fabian Deutsch 2014-07-16 07:07:35 UTC
It is like Matt and Ryan said, I was referring to the classic terminal size of 80 cols by 24 rows.

And I doubt that it is possible to fit the suggested layout into those dimensions.

But, can you come up with a layout suggestion which fits into the dimension? Then we can try to realize this.

Comment 10 Einav Cohen 2014-07-16 12:47:33 UTC
thanks for the clarification, guys. neither me nor the two UX designers I was consulting with knew that such resolution exists and all of were sure that you were referring to the "1280x1024" resolution - I apologize. 

@Liz - now that we know that "80x24" literally means "80x24": any creative ideas?

Comment 11 Liz 2014-07-17 13:06:11 UTC
Created attachment 918699 [details]
UX improvement idea for NIC details

Yes, thanks for the extra clarification.

A few of my thoughts from a UX perspective, keeping in mind the 80x24 constraints…

1) Is it possible to improve the spacing/alignment between field labels and values? I think if we can clean up where the extra space is put, it would make the current layout more readable to the user.
  - Align settings in the first column so they all have the same left alignment.
  - Reduce the amount of space between Radio options (IPv4 Bootprotocol and IPv6 Bootprotocol)
  - Include a bit more space between column 1 settings and column 2 settings.

Please see attachment.

Are any of these updates possible?

Thanks,
Liz

Comment 13 Fabian Deutsch 2015-09-17 15:07:23 UTC
This functionality will move to cockpit, where this bug does not apply anymore.


Note You need to log in before you can comment on or make changes to this bug.