Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098447 - [redhat-support-plugin-rhev] Clicking on refresh icon to refresh log file content doesn't show any in-progress icon
Summary: [redhat-support-plugin-rhev] Clicking on refresh icon to refresh log file con...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Spenser Shumaker
QA Contact: Jiri Belka
URL:
Whiteboard: subeng
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-16 08:31 UTC by Jiri Belka
Modified: 2015-02-11 18:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:13:54 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0211 normal SHIPPED_LIVE redhat-support-plugin-rhev bug fix and enhancement update 2015-02-11 23:11:47 UTC

Description Jiri Belka 2014-05-16 08:31:29 UTC
Description of problem:
Clicking on refresh icon to refresh log file content doesn't show any in-progress icon. If the file is huge and has got many new files, its "reload" takes time and the user doesn't know if anything is happening in the background.

There should be an overlay over currently loaded log file content with in-progress wheel icon to inform the user "we" are doing something.

Version-Release number of selected component (if applicable):
redhat-support-plugin-rhev-3.4.0-4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. select vdsm.log or some other huge file into Log Viewer
2. click refresh icon to update diplayed log file content
3.

Actual results:
no idea if it works or not if the file is huge as there's no in-progress wheel icon

Expected results:
let's clearly inform the user there's ongoing work in the background so he knows why is he waiting

Additional info:

Comment 2 Eyal Edri 2014-08-06 06:49:49 UTC
out of scope for 3.4.2, missing from tracker bug: [RHEV] 3.4.2 Bug tracker - https://bugzilla.redhat.com/show_bug.cgi?id=1123858.

moving to 3.4.3

Comment 4 Jiri Belka 2014-09-19 09:44:02 UTC
fail, i don't see any in-progress icon/circle, just the log get appended.

redhat-support-plugin-rhev-3.5.0-0.el6ev.noarch

Comment 6 Jiri Belka 2014-10-30 11:27:55 UTC
ok, redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch

Comment 7 Spenser Shumaker 2014-11-14 20:17:13 UTC
Cause: When the user clicked the refresh icon a in-progress icon was not show.
Consequence: The user would not know if a file refresh action was happening.
Fix: Display an in-progress icon when a file refresh is happening.
Result: The user now knows when a file refresh is happening.

Comment 8 Eyal Edri 2014-12-16 10:24:03 UTC
Spenser,
please mark the require_doc_text flag as '-' if any of these bugs needs doc for errata or ? if you need to document it and request assistance from doc team?
this is needed asap for the last rc build due this week.

Comment 10 errata-xmlrpc 2015-02-11 18:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0211.html


Note You need to log in before you can comment on or make changes to this bug.