Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098443 - [redhat-support-plugin-rhev] non-ascii char in 'User ID' in login dialog makes the dialog stucked
Summary: [redhat-support-plugin-rhev] non-ascii char in 'User ID' in login dialog make...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Spenser Shumaker
QA Contact: Jiri Belka
URL:
Whiteboard: subeng
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-16 08:22 UTC by Jiri Belka
Modified: 2015-02-11 18:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:13:50 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0211 normal SHIPPED_LIVE redhat-support-plugin-rhev bug fix and enhancement update 2015-02-11 23:11:47 UTC

Description Jiri Belka 2014-05-16 08:22:06 UTC
Description of problem:
non-ascii char in 'User ID' in login dialog makes the dialog stucked - no login failure, no success.

Version-Release number of selected component (if applicable):
redhat-support-plugin-rhev-3.4.0-4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Log Viewer
2. open login dialog
3. User ID: 字/汉字 + some password, click 'Sign in'

Actual results:
looks stucked (but can be closed with 'Cancel')

Expected results:
login failure or something relevant

Additional info:
"Chinese characters are logograms used in the writing of Chinese and some other Asian languages. They are called hanzi (漢字/汉字) in Chinese,[2] kanji in Japanese." (wikipedia, hehe)

Comment 1 Eyal Edri 2014-08-06 06:49:47 UTC
out of scope for 3.4.2, missing from tracker bug: [RHEV] 3.4.2 Bug tracker - https://bugzilla.redhat.com/show_bug.cgi?id=1123858.

moving to 3.4.3

Comment 3 Jiri Belka 2014-09-19 09:17:28 UTC
ok, redhat-support-plugin-rhev-3.5.0-0.el6ev.noarch

got 'Login Failed!'.

Comment 4 Spenser Shumaker 2014-11-14 20:15:22 UTC
Cause: The user could input non-ASCII text in the User ID field.
Consequence: The login become stuck.
Fix: Non-ASCII text is no long able to be submitted.
Result: The user can no longer submit non-Ascii text.

Comment 5 Eyal Edri 2014-12-16 10:23:59 UTC
Spenser,
please mark the require_doc_text flag as '-' if any of these bugs needs doc for errata or ? if you need to document it and request assistance from doc team?
this is needed asap for the last rc build due this week.

Comment 7 errata-xmlrpc 2015-02-11 18:13:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0211.html


Note You need to log in before you can comment on or make changes to this bug.