Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098438 - [redhat-support-plugin-rhev] 'Open a New Support Case' should trigger login dialog when not logged-in
Summary: [redhat-support-plugin-rhev] 'Open a New Support Case' should trigger login d...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-4.0.0-alpha
: 4.0.0
Assignee: Josh Kinlaw
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-16 08:08 UTC by Jiri Belka
Modified: 2016-03-10 12:39 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-10 12:39:34 UTC
oVirt Team: Sub-Eng
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Belka 2014-05-16 08:08:07 UTC
Description of problem:
'Open a New Support Case' should trigger login dialog when not logged-in. When one is not logged-in (Log Viewer) and he expands right-side minimalized 'Recommendations' pane and clicks on 'Open a New Suport Case', he gets

Error 401 Unauthorized

Obvously but the code could be clever enough to trigger login dialog. He login session is not established anyway so first check for session and if not then trigger login.

Version-Release number of selected component (if applicable):
redhat-support-plugin-rhev-3.4.0-4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Log Viewer, do not login inside RH Customer Portal
2. expand right-side 'Recommendations' pane
3. click 'Open a New Support Case'

Actual results:
Error 401 Unauthorized

Expected results:
trigger login to be more friendly :)

Additional info:

Comment 1 Eyal Edri 2014-08-06 06:49:49 UTC
out of scope for 3.4.2, missing from tracker bug: [RHEV] 3.4.2 Bug tracker - https://bugzilla.redhat.com/show_bug.cgi?id=1123858.

moving to 3.4.3

Comment 3 Jiri Belka 2014-09-19 09:28:33 UTC
fail, there's no popup dialog but two 'Unauthorized.' "orange" boxes. why two? see screenshot.

redhat-support-plugin-rhev-3.5.0-0.el6ev.noarch

Comment 4 Jiri Belka 2014-09-19 09:32:24 UTC
screenshot- https://bugzilla.redhat.com/attachment.cgi?id=939154 (i messed tabs with BZs)

Comment 5 Spenser Shumaker 2014-09-19 12:31:23 UTC
The two messages is a known issue and a fix is being worked on.  However I am confused on how you got in this state.  When selecting Red Hat Access: Support a modial dialog is forced.  However it looks like you went to open a case through the log viewer.  When using the log viewer a login is forced when the user selects "Red Hat Diagnose" which happens before the "Open a New Support Case" button is displayed.  Are you seeing different behavior?

Comment 6 Jiri Belka 2014-10-01 08:29:23 UTC
Steps to Reproduce:
1. Log Viewer, do not login inside RH Customer Portal
2. expand right-side 'Recommendations' pane
3. click 'Open a New Support Case'

so it states clearly what is the flow. If you go to 'Log Viewer' there appears 'Unauthorized' message, then you expand right-side arrow, the 'Unauthorized' message is still visible. Then you click on 'Open a New Support Case', (known) two 'Unauthorized' messages appear. The bug is about the fact that if it knows you are not logged in it should cause appearance of login dialog (like if one would lick on 'Log In' inside Log Viewer).

It has nothing to do with 'Red Hat Diagnose'.

Comment 7 Spenser Shumaker 2014-10-20 16:38:27 UTC
This is a bigger fix than initially thought.  Moving to be fixed in z-stream

Comment 11 Eyal Edri 2015-07-06 11:40:29 UTC
missed the build date, moving to 3.5.5,
please consult PM if you think this bug is urgent and should block 3.5.4

Comment 12 Josh Kinlaw 2015-09-08 14:40:51 UTC
Closing as won't fix. We don't force the user to log in because you should still be able to view logs without logging into the customer portal. If we force the user to login then they would never be able to see any logs without having a customer portal account.

If the user does elect to use the diagnose button then they will see the login popup.

Comment 13 Yaniv Lavi 2015-09-08 14:45:55 UTC
This is not the same flow as in log collector. This is when opening a new case after you viewed the logs or pressed the button to do that.

Comment 15 Keith Robertson 2015-09-08 17:11:36 UTC
(In reply to Yaniv Dary from comment #13)
> This is not the same flow as in log collector. This is when opening a new
> case after you viewed the logs or pressed the button to do that.

Yaniv, 
To open a "a new case after you viewed the logs" you must have pushed the "Red Hat Diagnose" button.  You cannot push the "Red Hat Diagnose" without either being already logged in or being presented with a modal dialog *to* login.  Hence, you cannot get to the page in the Log Viewer where the "Open a New Support Case" button is active without being logged in.


Keith


Note You need to log in before you can comment on or make changes to this bug.