Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098432 - [redhat-support-plugin-rhev] 'Red Hat Diagnose' can be submitted even without selected text
Summary: [redhat-support-plugin-rhev] 'Red Hat Diagnose' can be submitted even without...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Spenser Shumaker
QA Contact: Jiri Belka
URL:
Whiteboard: subeng
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-16 08:01 UTC by Jiri Belka
Modified: 2015-02-11 18:13 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:13:41 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0211 normal SHIPPED_LIVE redhat-support-plugin-rhev bug fix and enhancement update 2015-02-11 23:11:47 UTC

Description Jiri Belka 2014-05-16 08:01:32 UTC
Description of problem:
'Red Hat Diagnose' can be submitted even without selected text. The trick is to quickly double-click on the button, then it gets dark-blue color and then next submit would cause searching for Recommendations (or at least it seems so as there appears in-progress wheel icon).

This seems odd.

Version-Release number of selected component (if applicable):
redhat-support-plugin-rhev-3.4.0-4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. go to 'Log Viewer' tab
2. login into RH Customer Portal from this ui plugin
3. do not select any host/machine but quickly double-click 'Red Hat Diagnose' button and then click on it once again

Actual results:
search is executed, 'No solutions found.' displayed in _green_ background color

Expected results:
should not work, nothing is selected as pattern for search

Additional info:

Comment 2 Eyal Edri 2014-08-06 06:49:48 UTC
out of scope for 3.4.2, missing from tracker bug: [RHEV] 3.4.2 Bug tracker - https://bugzilla.redhat.com/show_bug.cgi?id=1123858.

moving to 3.4.3

Comment 4 Jiri Belka 2014-09-19 09:11:53 UTC
ok, as this button doesn't appear anymore before a log if selected - redhat-support-plugin-rhev-3.5.0-0.el6ev.noarch

Comment 5 Julie 2014-11-12 22:44:26 UTC
Hi Spenser,
If this bug requires doc text for errata release, please provide draft text in the following format:
Cause: 
Consequence: 
Fix: 
Result: 
The documentation team will review, edit, and approve the text. 
If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 6 Spenser Shumaker 2014-11-14 20:12:01 UTC
Cause: The Red Hat Diagnose button could be enabled without text being selected.
Consequence: The user could diagnose an empty text string, resulting no solutions being returned.
Fix: Disable the 'Red Hat Diagnose' button when no text is selected.
Result: The user can no longer click the button when text is not selected.

Comment 7 Eyal Edri 2014-12-16 10:24:02 UTC
Spenser,
please mark the require_doc_text flag as '-' if any of these bugs needs doc for errata or ? if you need to document it and request assistance from doc team?
this is needed asap for the last rc build due this week.

Comment 9 errata-xmlrpc 2015-02-11 18:13:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0211.html


Note You need to log in before you can comment on or make changes to this bug.