Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1098258 - A movement operation of raw sparse disk from file to block domain results in Raw preallocated disk, but reports its type wrongly in the webadmin
Summary: A movement operation of raw sparse disk from file to block domain results in ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.4.0
Assignee: Tal Nisan
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks: 1064068
TreeView+ depends on / blocked
 
Reported: 2014-05-15 15:21 UTC by Ori Gofen
Modified: 2016-05-26 01:47 UTC (History)
13 users (show)

Fixed In Version: av9.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27793 master MERGED core: BaseImagesCommand - update disk volume type Never
oVirt gerrit 27813 ovirt-engine-3.4 MERGED core: BaseImagesCommand - update disk volume type Never

Description Ori Gofen 2014-05-15 15:21:10 UTC
Description of problem:

When moving a thin provision NFS disk to ISCSI domain,a Raw sparse disk
becomes Raw preallocated disk after the movement.

the web admin interface reports wrongly:"Allocation Policy -> thin provision"
but the actual size of the disk increases to its virtual size,and ,as stated,
the allocation policy also changes.

copy paste from terminal's vdsClient, before and after the movement:

[root@camel-vdsb ~]# vdsClient -s 0 getVolumeInfo 61a3e5e4-d191-4652-8bcc-50ea53b2ae11 $spuuid d05a7628-1750-4ca8-b77a-5917040df844 813a1759-1cb5-418c-b0af-e9786fa901cc
	status = OK
	domain = 61a3e5e4-d191-4652-8bcc-50ea53b2ae11
	capacity = 4294967296
	voltype = LEAF
	description = 
	parent = 00000000-0000-0000-0000-000000000000
	format = RAW
	image = d05a7628-1750-4ca8-b77a-5917040df844
	uuid = 813a1759-1cb5-418c-b0af-e9786fa901cc
	disktype = 2
	legality = LEGAL
	mtime = 1400164357
	apparentsize = 4294967296
	truesize = 24576
	type = SPARSE
	children = []
	pool = 
	ctime = 1400164357

[root@camel-vdsb ~]# vdsClient -s 0 getVolumeInfo $sduuid $spuuid d05a7628-1750-4ca8-b77a-5917040df844 813a1759-1cb5-418c-b0af-e9786fa901cc	status = OK
	domain = f9eeafd7-4686-4368-8102-af590e285a27
	capacity = 4294967296
	voltype = LEAF
	description = 
	parent = 00000000-0000-0000-0000-000000000000
	format = RAW
	image = d05a7628-1750-4ca8-b77a-5917040df844
	uuid = 813a1759-1cb5-418c-b0af-e9786fa901cc
	disktype = 2
	legality = LEGAL
	mtime = 1400164929
	apparentsize = 4294967296
	truesize = 4294967296
	type = PREALLOCATED
	children = []
	pool = 
	ctime = 1400164928

Version-Release number of selected component (if applicable):

vdsm-4.14.7-2.el6ev.x86_64
rhevm-3.4.0-0.20.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:

Setup:Have a dc with 2 domains(one NFS,one ISCSI)

1.create a floating on NFS (thin provision) with or without vm  
2.move it to ISCSI domain

Actual results:
The web admin ui reports a thin-provision disk on ISCSI domain,but
actually the disk is preallocated.

Expected results:
The disk should be moved to ISCSI domain and the allocation policy should change to be 'cow sparse',(plus,disk size should not increase above the actual size it had at the NFS domain)

Additional info:
I have added the logs,but I don't think there's much information over there.

Comment 1 Daniel Erez 2014-05-15 17:47:00 UTC
@Tal - is it related to moving disks on different storage types changes?

Comment 2 Daniel Erez 2014-05-18 10:22:09 UTC
RAW/Sparse is not supported in iSCSI/FCP, hence the disk is correctly typed as preallocated. The issue is merely updating the engine DB with the correct value.

Comment 3 Ori Gofen 2014-05-21 13:10:14 UTC
verified on av9.2

Comment 4 Ori Gofen 2014-05-21 13:10:50 UTC
verified on av9.2 (only ui bug)

Comment 5 Itamar Heim 2014-06-12 14:08:36 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.