Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1097702 - MinimalVersionCheck job has incorrect instructions for upgrade of engine & dwh.
Summary: MinimalVersionCheck job has incorrect instructions for upgrade of engine & dwh.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.5.0
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard: infra
Depends On: 1090914
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-14 11:23 UTC by Yaniv Lavi
Modified: 2016-02-10 19:20 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1090914
Environment:
Last Closed: 2015-02-11 18:15:04 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC
oVirt gerrit 27101 None None None Never
oVirt gerrit 27112 None None None Never
oVirt gerrit 34810 master ABANDONED packaging: set dwh_version by version in spec Never

Comment 2 Petr Matyáš 2014-09-09 11:10:59 UTC
I'am not sure how to verify this, if I have 3.4 and try to upgrade with yum only engine to 3.5, yum wants to upgrade dwh and reports as well because of dependencies. And if I check MinimalETLVersion in db, it's 3.5.0.

Comment 3 Shirly Radco 2014-09-16 10:54:43 UTC
Please change the value of the version from 3.5.0 to 3.5.1 and the engine will think it was upgraded and run engine-setup. The setup should fail because the dwh and reports were not upgraded as well.

Comment 4 Petr Matyáš 2014-10-23 12:04:15 UTC
I don't seem to be able to reproduce or I'am doing something wrong. I have 3.5 engine and dwh, I change the value of MinimalETLVersion in both tables to 3.5.1 and run engine-setup, but it successfully finishes and changes the value in both tables back to 3.5.0.

Comment 5 Yaniv Lavi 2014-11-03 08:36:51 UTC
This should be test on separate hosts only. It's the only way the engine or dwh can be updated separately and become incompatible.
For example:
Change minimalETL to 3.5.1 in engine and install 3.5.0 dwh. this should prompt a error.



Yaniv

Comment 6 Petr Matyáš 2014-11-03 13:41:15 UTC
No, it doesn't. I installed 3.5 engine, changed MinimalETLVersion to 3.5.1. On another host I installed 3.5 dwh and it worked without any problems or error messages.

Comment 7 Yedidyah Bar David 2014-11-04 07:27:52 UTC
(In reply to Petr Matyáš from comment #6)
> No, it doesn't. I installed 3.5 engine, changed MinimalETLVersion to 3.5.1.
> On another host I installed 3.5 dwh and it worked without any problems or
> error messages.

No idea how come.

Now did that too, failed as expected. The command 'service ovirt-engine-dwhd start' didn't fail - it outputted nothing and returned 0. But /var/log/messages has:

ovirt-engine-dwhd: ERROR run:532 Error: process terminated with status code 4

And /var/log/ovirt-engine-dwh/ovirt-engine-dwhd.log has:

2014-11-04 09:20:58|ETL Service Started
2014-11-04 09:20:58|ptZvqG|9HyEpc|9HyEpc|OVIRT_ENGINE_DWH|MinimalVersionCheck|Default|5|tDie|tDie_1|2014-11-04 09:20:58|You have upgraded your oVirt Engine and now require an upgrade of the ovirt-engine-dwh package. Please run engine-setup to upgrade the version. Service will now exit.|4
2014-11-04 09:20:58|You have upgraded your oVirt Engine and now require an upgrade of the ovirt-engine-dwh package. Please run engine-setup to upgrade the version. Service will now exit.
Exception in component tRunJob_2
java.lang.RuntimeException: Child job running failed
        at ovirt_engine_dwh.historyetl_3_5.HistoryETL.tRunJob_2Process(HistoryETL.java:7192)
        at ovirt_engine_dwh.historyetl_3_5.HistoryETL$3.run(HistoryETL.java:10192)
2014-11-04 09:20:58|9HyEpc|9HyEpc|9HyEpc|OVIRT_ENGINE_DWH|HistoryETL|Default|6|Java Exception|tRunJob_2|java.lang.RuntimeException:Child job running failed|1
2014-11-04 09:20:58|ETL Service Stopped

If you do not see similar things, please let us access the machines where you do that.

BTW, I did this on fedora 19, with its systemd, which I still do not know well. After dwhd failed as above, I changed minimaletlversion back to '3.5.0' and ran again 'service ovirt-engine-dwhd start' which got stuck. After spending too much time on this, I guess this is a result of the service conf having 'RestartSec=3600'. I didn't try to wait an hour and see if it works. Running 'service ovirt-engine-dwhd stop' and then 'service ovirt-engine-dwhd start' worked.

Comment 8 Petr Matyáš 2014-11-04 09:51:25 UTC
I have RHEL 6.6 on both machines, no error in log file.

Comment 10 Yedidyah Bar David 2014-11-04 10:50:00 UTC
I easily reproduced by setting minimaletlversion to '3.5.2'.

/usr/share/ovirt-engine-dwh/services/ovirt-engine-dwhd/ovirt-engine-dwhd.conf has:

DWH_VERSION="3.5.1"

In dwh's dist-git I see:

Source:         http://resources.ovirt.org/pub/src/ovirt-engine-dwh/ovirt-engine-dwh-3.5.1-5_master.tar.gz

Seems like our downstream build is based on upstream 3.5.1 (although I can't see that in git tags or branches). Not sure how this happened, or if it requires any change or fix. To avoid confusion, it might be better to change the version number of the package itself to 3.5.1.

Comment 11 Petr Matyáš 2014-11-04 12:26:03 UTC
OK, when I set 3.5.2 in engine db, I get:
[ ERROR ] Failed to execute stage 'Setup validation': Minimal supported DWH version on the engine side is 3.5.2, and is incompatible with installed DWH package version 3.5.1. Please upgrade or downgrade engine or DWH as applicable.

I suppose this is correct behaviour?

Comment 12 Yaniv Lavi 2014-11-04 12:35:48 UTC
(In reply to Yedidyah Bar David from comment #10)
> I easily reproduced by setting minimaletlversion to '3.5.2'.
> 
> /usr/share/ovirt-engine-dwh/services/ovirt-engine-dwhd/ovirt-engine-dwhd.
> conf has:
> 
> DWH_VERSION="3.5.1"
> 
> In dwh's dist-git I see:
> 
> Source:        
> http://resources.ovirt.org/pub/src/ovirt-engine-dwh/ovirt-engine-dwh-3.5.1-
> 5_master.tar.gz
> 
> Seems like our downstream build is based on upstream 3.5.1 (although I can't
> see that in git tags or branches). Not sure how this happened, or if it
> requires any change or fix. To avoid confusion, it might be better to change
> the version number of the package itself to 3.5.1.

This needs a fix. I'm moving to assigned. The conf file should be updated with correct spec version.
This should be added by adding a file to conf.d that sets version to the spec version. This way we will have less issues with someone forgetting to change version in DWH context.

Comment 13 Yedidyah Bar David 2014-11-04 14:33:38 UTC
(In reply to Yaniv Dary from comment #12)
> (In reply to Yedidyah Bar David from comment #10)
> > I easily reproduced by setting minimaletlversion to '3.5.2'.
> > 
> > /usr/share/ovirt-engine-dwh/services/ovirt-engine-dwhd/ovirt-engine-dwhd.
> > conf has:
> > 
> > DWH_VERSION="3.5.1"
> > 
> > In dwh's dist-git I see:
> > 
> > Source:        
> > http://resources.ovirt.org/pub/src/ovirt-engine-dwh/ovirt-engine-dwh-3.5.1-
> > 5_master.tar.gz
> > 
> > Seems like our downstream build is based on upstream 3.5.1 (although I can't
> > see that in git tags or branches). Not sure how this happened, or if it
> > requires any change or fix. To avoid confusion, it might be better to change
> > the version number of the package itself to 3.5.1.
> 
> This needs a fix. I'm moving to assigned. The conf file should be updated
> with correct spec version.
> This should be added by adding a file to conf.d that sets version to the
> spec version. This way we will have less issues with someone forgetting to
> change version in DWH context.

Why? Why not just use the upstream version we base on? Do you see any reason we might need to divert?

(In reply to Petr Matyáš from comment #11)
> OK, when I set 3.5.2 in engine db, I get:
> [ ERROR ] Failed to execute stage 'Setup validation': Minimal supported DWH
> version on the engine side is 3.5.2, and is incompatible with installed DWH
> package version 3.5.1. Please upgrade or downgrade engine or DWH as
> applicable.
> 
> I suppose this is correct behaviour?

It is, but not for this bug :-) You should have just stopped and started dwhd, and check its log. setup also checks this, but that's a different issue.

Comment 14 Yaniv Lavi 2014-11-05 11:10:54 UTC
(In reply to Yedidyah Bar David from comment #13)
> (In reply to Yaniv Dary from comment #12)
> > (In reply to Yedidyah Bar David from comment #10)
> >
> > This needs a fix. I'm moving to assigned. The conf file should be updated
> > with correct spec version.
> > This should be added by adding a file to conf.d that sets version to the
> > spec version. This way we will have less issues with someone forgetting to
> > change version in DWH context.
> 
> Why? Why not just use the upstream version we base on? Do you see any reason
> we might need to divert?

Upstream versions are not the same as downstream version. Compatibility is based 
on the version and things can divert. We need to keep it simple as possible.

Comment 15 Yaniv Lavi 2014-11-09 12:33:46 UTC
I have come to the conclusion that it would be best to keeps things as they are and just make sure the etl version is up to date in context. It will be easier to relay on upstream compatibility versions in d\s, since it's internal and not customer facing and we do no want to over complicate with d\s minimal version in engine. 
Petr, please change version to higher then existing in dwh. It's the DWH version in upstream, this is also the version listed in the engine.

Comment 17 errata-xmlrpc 2015-02-11 18:15:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.