Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1097165 - The CLI info command doesn't report version numbers correctly
Summary: The CLI info command doesn't report version numbers correctly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Ilanit Stein
URL:
Whiteboard: infra
Depends On:
Blocks: 1097331 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-13 09:36 UTC by Juan Hernández
Modified: 2016-02-10 19:20 UTC (History)
9 users (show)

Fixed In Version: rhevm-cli-3.4.0.6-4.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1097331 (view as bug list)
Environment:
Last Closed: 2014-06-20 17:42:03 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
Patch to fix the version number reporting (deleted)
2014-05-13 09:41 UTC, Juan Hernández
no flags Details | Diff

Description Juan Hernández 2014-05-13 09:36:40 UTC
Description of problem:

The rhevm-shell "info" command doesn't report the version numbers of the SDK and the CLI correctly.

Version-Release number of selected component (if applicable):
rhevm-cli-3.4.0.6-3.el6ev.noarch


How reproducible:
Always.


Steps to Reproduce:
1. Start the rhevm-shell.
2. Run the "info" command.

Actual results:
backend version: 3.4
sdk version    : 0.0.0.0
cli version    : 0.0.0.0
python version : 2.6.6.final.0

Expected results:

backend version: 3.4
sdk version    : 3.4.1
cli version    : 3.4.0.6
python version : 2.6.6.final.0

Additional info:

This happens because the CLI is checking the versions of the packages using the upstream names ovirt-engine-sdk-python and ovirt-shell.

Comment 1 Juan Hernández 2014-05-13 09:41:19 UTC
Created attachment 895077 [details]
Patch to fix the version number reporting


Note You need to log in before you can comment on or make changes to this bug.