Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1095223 - Import VM fail on 3.3 "Cluster doesn't exist", though it does exist.
Summary: Import VM fail on 3.3 "Cluster doesn't exist", though it does exist.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Omer Frenkel
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-07 10:21 UTC by Ilanit Stein
Modified: 2015-10-27 23:57 UTC (History)
15 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 08:26:53 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs (deleted)
2014-05-07 10:24 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27998 master MERGED core: don't check for vm.getVdsGroupId on import vm Never

Description Ilanit Stein 2014-05-07 10:21:59 UTC
Description of problem:
On version: rhevm-3.5.0-0.1000.2890.efcac0a.master.el6ev.noarch, 
export VM fail for 3.3 cluster.

Steps to Reproduce:
It was found on this test:
http://jenkins-ci.eng.lab.tlv.redhat.com/view/0%20Unstable%203.5/job/rhevm_3.5_automation_coretools_two_hosts_restapi_vms_nfs_rest_factory/27/

In the test we export VM, on 3.3 dc/cluster, remove the VM locally, 
and then import it.
The Import fail on backend error:
"Cannot import VM. The relevant Cluster doesn't exist."

Relevant section from engine.log: 
2014-05-05 15:29:59,963 INFO  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-8) [476] Lock Acquired to object EngineLock [exclusiveLocks= key: restvm_export value: VM_NAME
, sharedLocks= key: 6eb9d103-d4e2-41ab-a242-fc43c35aa5f0 value: REMOTE_VM
]
2014-05-05 15:29:59,963 WARN  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-8) [476] CanDoAction of action ImportVm failed. Reasons:VAR__ACTION__IMPORT,VAR__TYPE__VM,ACTION_TYPE_FAILED_CLUSTER_CAN_NOT_BE_EMPTY
2014-05-05 15:29:59,964 INFO  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-8) [476] Lock freed to object EngineLock [exclusiveLocks= key: restvm_export value: VM_NAME
, sharedLocks= key: 6eb9d103-d4e2-41ab-a242-fc43c35aa5f0 value: REMOTE_VM
]
2014-05-05 15:29:59,968 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp-/127.0.0.1:8702-8) Operation Failed: [Cannot import VM. The relevant Cluster doesn't exist.]

Comment 1 Ilanit Stein 2014-05-07 10:24:54 UTC
Created attachment 893191 [details]
logs

Comment 2 Omer Frenkel 2014-05-11 06:28:54 UTC
does this happen all the time? is this reproducible manually as well?

Comment 3 Ilanit Stein 2014-05-11 06:47:20 UTC
Yes it happens all the time, ever since this test started to run on rhevm 3.5:
http://jenkins-ci.eng.lab.tlv.redhat.com/view/0%20Unstable%203.5/job/rhevm_3.5_automation_coretools_two_hosts_restapi_vms_nfs_rest_factory/

As for manual reproduce - I'll update once I'll have a 3.5 setup.

Comment 4 Pedro Aleluia 2014-05-19 14:59:10 UTC
Same problem on 3.5 pre

Comment 6 Ilanit Stein 2014-05-25 09:01:46 UTC
This bug happen on a 3.5 setup, for DC\Cluster 3.4 as well
(Seen that looking on recent build of this test: http://jenkins-ci.eng.lab.tlv.redhat.com/view/0%20Unstable%203.5/job/rhevm_3.5_automation_coretools_two_hosts_restapi_vms_nfs_rest_factory/)

Patch seem to resolve the problem, since for 5 test builds, since May 22, this same import VM test case has been passing.

Comment 7 Ilanit Stein 2014-07-29 10:27:29 UTC
This failure do not appear any more for that same jenkins job, mentioned in description, for run at Jul 29.

Comment 8 Omer Frenkel 2015-02-17 08:26:53 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.