Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1095148 - Abort TUI and auto-install when upgrading from to a new major release
Summary: Abort TUI and auto-install when upgrading from to a new major release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-07 08:22 UTC by haiyang,dong
Modified: 2016-02-10 20:08 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:57:04 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 29084 None None None Never

Description haiyang,dong 2014-05-07 08:22:04 UTC
Description of problem:
The grub miss the backup version after upgrade it from rhevh-6.5-20140430.0 into rhevh-7.0-20140424.0.iso.

Version-Release number of selected component (if applicable):
rhevh-7.0-20140424.0.iso 
ovirt-node-3.1.0-0.2.20140424gitbfdfc00.el7

How reproducible:
100%

Steps to Reproduce:
1. Clean into rhevh-6.5-20140430.0
2. Upgrade it to rhevh-7.0-20140424.0.iso 
3. focus on grub.

Actual results:
The grub miss the backup version after upgrade it from rhevh6.5 into rhevh7.
[root@dhcp-66-72-152 /]# cat /dev/.initramfs/live/grub2/grub.cfg 

#default saved
set timeout=5
#hiddenmenu
menuentry "RHEV-H 7.0-20140424.0.el7" {
set root=(hd0,2)
search --no-floppy --label Root --set root
linux /vmlinuz0 root=live:LABEL=Root ro rootfstype=auto rootflags=ro rd.live.image rd.live.check rd.lvm=0  crashkernel=128M elevator=deadline quiet max_loop=256 rd.luks=0 rd.md=0 rd.dm=0 nomodeset
initrd /initrd0.img

Expected results:

Additional info:
Maybe this is due to rhevh7 used grub2-install and rhevh6.5 used grub-install

Comment 1 Ying Cui 2014-05-08 06:41:06 UTC
ovirt-node 3.1 bug.

Comment 3 Ying Cui 2014-06-11 05:40:00 UTC
As far as I know, RHEL support upgrading between major versions like rhel 6.5 upgrade to rhel 7.0.

Comment 5 Fabian Deutsch 2014-06-12 11:01:21 UTC
Haiyang,

how did you perform the upgrade via the TUI or auto-install?

And: Upgrades to a new major version is currently not supported.

Comment 6 haiyang,dong 2014-06-16 05:14:15 UTC
(In reply to Fabian Deutsch from comment #5)
> Haiyang,
> 
> how did you perform the upgrade via the TUI or auto-install?

Hey Fabian,

I perform the upgrade rhevh from "rhevh-6.5-20140430.0" into "rhevh-7.0-20140424.0.iso" via the TUI and auto-install.
> 
> And: Upgrades to a new major version is currently not supported.

Seems it's better to abort rhevh TUI and auto-install when upgrading from to a new major release.

Comment 7 Fabian Deutsch 2014-07-24 16:02:39 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 9 haiyang,dong 2014-10-13 05:29:08 UTC
Test version:
rhevh-7.0-20141006.0.el7ev.iso
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch

Now check that rhevh-7.0-20141006.0.el7ev.iso will abort TUI and auto-install when upgrading from to a new major release(eg: upgrade rhevh from rhev-hypervisor6-6.5-20140821.1.iso into rhevh-7.0-20141006.0.el7ev.iso), also it will prompt to users that "Major version upgrades are not allowed or unsupported" info.

so this bug has been fixed,change the status into "VERIFIED".

Comment 12 errata-xmlrpc 2015-02-11 20:57:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.