Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1095144 - UI crash when select <Set Console Path> in status page
Summary: UI crash when select <Set Console Path> in status page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-07 08:18 UTC by wanghui
Modified: 2016-07-04 00:39 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:56:58 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
UI crash after select <Set Console path> (deleted)
2014-05-07 08:18 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 27648 master MERGED Properly initialize the labels on the console page Never

Description wanghui 2014-05-07 08:18:28 UTC
Created attachment 893154 [details]
UI crash after select <Set Console path>

Description of problem:
The UI crash when select the <Set Console Path> in status page.

Version-Release number of selected component (if applicable):
rhevh-7.0-20140424.0.iso 
ovirt-node-3.1.0-0.2.20140424gitbfdfc00.el7

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh-7.0-20140424.0.iso 
2. Select the <Set Console Path> in Status page

Actual results:
1. It report an error appeared in UI and UI crashed as set_console_path.png shows.

Expected results:
1. It should let user to set the console path.

Additional info:

Comment 1 Ying Cui 2014-05-08 06:43:47 UTC
ovirt-node 3.1 bug.

Comment 2 Fabian Deutsch 2014-07-24 16:03:00 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 4 wanghui 2014-10-13 06:29:36 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

Test step:
1. Install rhev-hypervisor7-7.0-20141006.0.el7ev
2. Select the <Set Console Path> in Status page
   Console path:        /dev/ttyS0,115200n8
3. Check grub conf file

Test result:
1. Console path can be saved without error.
2. /dev/.initramfs/live/grub2/grub.cfg can save the configuration.

TUI can set console path without error now. So this issue is fixed in rhev-hypervisor7-7.0-20141006.0.el7ev. Change the status from ON_QA to Verified.

Comment 5 wanghui 2014-10-24 02:30:12 UTC
This issue only concern the scenario which is in BIOS mode, for UEFI mode please refer bug#1046887.

Comment 8 errata-xmlrpc 2015-02-11 20:56:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.