Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1095138 - NFSv4 domain set up encounter error
Summary: NFSv4 domain set up encounter error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-07 08:08 UTC by wanghui
Modified: 2016-02-10 20:03 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:56:42 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
nfsv4 transaction page (deleted)
2014-05-07 08:08 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 28073 master MERGED unblacklist needed daemons for nfsv4 client side idmapping Never
oVirt gerrit 33796 master MERGED rhevh7-post: keep files in /var/lib/nfs Never

Description wanghui 2014-05-07 08:08:42 UTC
Created attachment 893150 [details]
nfsv4 transaction page

Description of problem:
Set up NFSv4 Domain encouneter error like nfsv4.png shows.

Version-Release number of selected component (if applicable):
rhevh-7.0-20140424.0.iso 
ovirt-node-3.1.0-0.2.20140424gitbfdfc00.el7

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh-7.0-20140424.0.iso 
2. Configure network
3. Set up NFSv4 Domain name

Actual results:
1. It reports an error occurred in Transaction page.

Expected results:
1. It should set up the nfsv4 domain correctly.

Additional info:

Comment 2 Ying Cui 2014-05-08 06:40:16 UTC
ovirt-node 3.1 bug.

Comment 3 Joey Boggs 2014-05-24 01:32:34 UTC
For nfsv4, the rpcidmap service has dependencies and requires a few of the server daemons that also play client roles.

Comment 4 Fabian Deutsch 2014-07-14 14:22:07 UTC
Moving to 3.5 as it is related to 7.0.

Comment 5 Fabian Deutsch 2014-07-24 16:03:04 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 7 cshao 2014-09-28 06:55:10 UTC
Test version:
rhev-hypervisor7-7.0-20140926.0.iso
ovirt-node-3.1.0-0.17.20140925git29c3403.el7.noarch

This issue is still exist in rhev-hypervisor7-7.0-20140926.0.iso.
An error occurred while applying the changes:
Command '[' service', 'rpcidmapd', 'restart']' returned non-zero exit status 1

So change the status from ON_QA to Assigned.

Comment 10 Fabian Deutsch 2014-10-06 17:43:16 UTC
Thanks Douglas!

Comment 11 wanghui 2014-10-13 06:37:04 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

Test step:
1. Install rhev-hypervisor7-7.0-20141006.0.el7ev
2. Configure network
3. Set up NFSv4 Domain name

Test result:
1. The NFSv4 domain name can be setted up without error in TUI.

So this issue is fixed in rhev-hypervisor7-7.0-20141006.0.el7ev. When the status change to ON_QA, I will verify it then.

Comment 12 wanghui 2014-10-14 02:30:05 UTC
According to comment#11, this issue is fixed in rhev-hypervisor7-7.0-20141006.0.el7ev. Change the status from ON_QA to Verified.

Comment 15 errata-xmlrpc 2015-02-11 20:56:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.