Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1094552 - Use the IPv6 configuration of before NIC when set up another NIC without IPv6 configuration
Summary: Use the IPv6 configuration of before NIC when set up another NIC without IPv6...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-06 02:42 UTC by wanghui
Modified: 2016-02-10 20:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:56:03 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 27480 master MERGED Apply default disable on network details page Never

Description wanghui 2014-05-06 02:42:48 UTC
Description of problem:
It will use the before NIC configuration of IPv6 when set up another NIC without IPv6 configuration.

Version-Release number of selected component (if applicable):
rhevh-6.5-20140430.0.iso
ovirt-node-3.0.1-18.el6_5.10.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhevh-6.5-20140430.0.iso.
2. Configure eth0 with ipv4 dhcp and ipv6 dhcp mode.
3. Configure eth1 with ipv4 dhcp.
4. Check the eth1 configuration file.

Actual results:
1. After step3, eth1 can also get ipv6 dhcp address. 
2. After step4, the output is as follows.
# cat /etc/sysconfig/network-scripts/ifcfg-eth1 
  BOOTPROTO="dhcp"
  DEVICE="eth0"
  DHCPV6C="yes"
  HWADDR="52:54:00:2c:16:e3"
  IPV6FORWARDING="no"
  IPV6INIT="yes"
  IPV6_AUTOCONF="no"
  ONBOOT="yes"
  PEERNTP="yes"
3. After step5, the eth1 IPv6 set up DHCP in NIC details page.

Expected results:
1. After step3, eth1 should not get ipv6 dhcp address.
2. After step4, eth1 should not have the IPv6 configured file.
3. After step5, eth1 should not set IPv6 DHCP in NIC details page.

Additional info:

Comment 1 Fabian Deutsch 2014-05-06 19:13:01 UTC
Please update the unittest as well.

Comment 2 Fabian Deutsch 2014-07-24 16:02:59 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 4 wanghui 2014-12-18 06:51:29 UTC
Test Version:
rhev-hypervisor6-6.6-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch

Test step:
1. Clean install rhev-hypervisor6-6.6-20141212.0.iso.
2. Configure eth0 with ipv4 dhcp and ipv6 dhcp mode.
3. Configure eth1 with ipv4 dhcp.
4. Check the eth1 configuration file.

Test result:
1. After step4, eth1 can be configured as ipv4 dhcp.

So this issue is fixed in rhev-hypervisor6-6.6-20141212.0.iso. Change the status from ON_QA to Verified.

Comment 6 errata-xmlrpc 2015-02-11 20:56:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.