Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1094395 - perl-IPC-Run make check failure for ppc64le archi
Summary: perl-IPC-Run make check failure for ppc64le archi
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-IPC-Run
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-05-05 15:07 UTC by Michel Normand
Modified: 2014-05-06 14:08 UTC (History)
3 users (show)

Fixed In Version: perl-IPC-Run-0.92-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-06 14:08:13 UTC


Attachments (Terms of Use)
IPC-Run-0.92-RT20105.patch from cpan bz 20105 (deleted)
2014-05-05 15:07 UTC, Michel Normand
no flags Details

Description Michel Normand 2014-05-05 15:07:27 UTC
Created attachment 892578 [details]
IPC-Run-0.92-RT20105.patch from cpan bz 20105

Description of problem: perl-IPC-Run make check failure for ppc64le archi


Version-Release number of selected component (if applicable):
perl-IPC-Run-0.92-4.fc21

Steps to Reproduce:
1. fedpkg clone -a perl-IPC-Run
2. fedpkg srpm
3. fedpkg mockbuild

Actual results:
===
...
# IO::Tty 1.10, IO::Pty 1.10
#   Failed test at t/pty.t line 147.
#          got: 'HELLO^M
# hello'
#     expected: '(?^i:^(?:hello\r?\n){2}(?!\n)$)'
#   Failed test at t/pty.t line 170.
#          got: 'hello'
#     expected: '(?^:^hello\r?\n(?!\n)$)'
#   Failed test at t/pty.t line 198.
#          got: 'hello^M
# HELLO^M
# hello'
#     expected: '(?^i:^(?:hello\r?\n){3}(?!\n)$)'
# Looks like you failed 3 tests of 32.
t/pty.t ......................
Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/32 subtests
===

Additional info:
The IPC-Run-0.92-RT20105.patch placed in attachement
retrieved from https://rt.cpan.org/Public/Bug/Display.html?id=20105#txn-1306043
is sufficient to solve the problem for ppc64le archi.

Comment 1 Paul Howarth 2014-05-06 14:08:13 UTC
Test suite patch applied in perl-IPC-Run-0.92-5.fc21.


Note You need to log in before you can comment on or make changes to this bug.