Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1094169 - perl-Params-Validate make check error
Summary: perl-Params-Validate make check error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Params-Validate
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-05-05 08:37 UTC by Michel Normand
Modified: 2014-05-17 06:30 UTC (History)
4 users (show)

Fixed In Version: perl-Params-Validate-1.08-8.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-05 23:34:08 UTC


Attachments (Terms of Use)
tstspell.pl perl script (need compagnion testspell.input.pm) (deleted)
2014-05-05 08:37 UTC, Michel Normand
no flags Details
tstspell.input.pm data used by tstspell.pl (deleted)
2014-05-05 08:39 UTC, Michel Normand
no flags Details

Description Michel Normand 2014-05-05 08:37:46 UTC
Created attachment 892455 [details]
tstspell.pl perl script (need compagnion testspell.input.pm)

Description of problem: perl-Params-Validate make check error while building on ppc64le new architecture.


Version-Release number of selected component (if applicable):
perl-Params-Validate-1.08-6.fc21

How reproducible:


Steps to Reproduce:
1.fedpkg clone -a perl-Params-Validate
2.fedpkg srpm
3.fedpkg mockbuild

Actual results:
...
#   Failed test 'POD spelling for blib/lib/Params/Validate.pm'
#   at t/release-pod-spell.t line 31.
# Errors:
#     'globals
# Looks like you failed 1 test of 7.
t/release-pod-spell.t ................... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/7 subtests 
...

Additional info:
The attached perl script is a code snippet that mimic the failing perl-Params-Validate package. This snippet failed on ppc64le and ppc64 architectures.
The problem is either:
* in the data set in script (the single quote as first element of __DATA__)
* the add_stopwords or hunspell functions.

Comment 1 Michel Normand 2014-05-05 08:39:10 UTC
Created attachment 892456 [details]
tstspell.input.pm data used by tstspell.pl

Comment 2 Ralf Corsepius 2014-05-05 11:26:51 UTC
Well, I am pretty much clueless about what to do with this BZ.

perl-Params-Validate has always had problems with its pod-checks.
In Fedora, I have been trying to work around these by applying a patch (Params-Validate-1.08.diff in git).

Seemingly this patch ceased being functional by some other (yet undetermined) changes in Fedora. It used to work for f19, f20 and rawhide, but currently fails for f20 and rawhide. F19 still builds fine. That said, I do not think this issue has anything to do with ppc64, but is a general issue somewhere.

The big questions, I don't know the answer to, to me is: Where/what is cause?
A potential fix would depend on the answer to this question.

I can easily modify my patch to let the package build on F20/rawhide again, however with this change applied, building fails on f19.

A last-resort work-around to all this would be to disable t/release-pod-spell.t or all release tests. It's something I have been doing in more recent packages, because many upstream maintainers actively discourage packagers to execise these :(

Comment 3 Menanteau Guy 2014-05-05 16:46:13 UTC
(In reply to Ralf Corsepius from comment #2)
> Well, I am pretty much clueless about what to do with this BZ.
> 
> perl-Params-Validate has always had problems with its pod-checks.
> In Fedora, I have been trying to work around these by applying a patch
> (Params-Validate-1.08.diff in git).
> 
> Seemingly this patch ceased being functional by some other (yet
> undetermined) changes in Fedora. It used to work for f19, f20 and rawhide,
> but currently fails for f20 and rawhide. F19 still builds fine. That said, I
> do not think this issue has anything to do with ppc64, but is a general
> issue somewhere.
> 
> The big questions, I don't know the answer to, to me is: Where/what is cause?
> A potential fix would depend on the answer to this question.
> 
> I can easily modify my patch to let the package build on F20/rawhide again,
> however with this change applied, building fails on f19.
> 
> A last-resort work-around to all this would be to disable
> t/release-pod-spell.t or all release tests. It's something I have been doing
> in more recent packages, because many upstream maintainers actively
> discourage packagers to execise these :(

Hi, I tried also to understand this problem without success (seems relative to the way hunspell is handling simple quote).
I checked a workaround by adding 'globals (without last quote at the end) in your Params-Validate-1.08.diff patch and this make the test pass on rawhide/ppc64le. 
I don't have a f19 available so I didn't test it on f19 and perhaps is what you referenced in your comment by saying "I can easily modify my patch to let the package build on F20/rawhide again". 
I just wanted to signal it in case this workaround passes on f19 (worth a try).

Comment 4 Ralf Corsepius 2014-05-05 23:04:19 UTC
(In reply to Menanteau Guy from comment #3)
> (In reply to Ralf Corsepius from comment #2)
 
> Hi, I tried also to understand this problem without success (seems relative
> to the way hunspell is handling simple quote).
This is my understanding, too. My gut feeling is, there is a quoting bug somewhere.

> I checked a workaround by adding 'globals (without last quote at the end) in
> your Params-Validate-1.08.diff patch and this make the test pass on
> rawhide/ppc64le. 
Exactly. This is the "easily patch work-around", I was referring to above.

> I don't have a f19 available so I didn't test it on f19 and perhaps is what
> you referenced in your comment by saying "I can easily modify my patch to
> let the package build on F20/rawhide again". 
Exactly. When using "'globals" instead of "'globals'", building for f19 fails.

However, ... adding both "'globals" and "'globals'" works on f19, f20 and rawhide! I guess, I am going to add this.


BTW, wrt. test-building for f19, you could try
- using "mock":
yum install mock
mock -r fedora-19-<x86_64,i386> perl-Params-Validate-<..>.src.rpm

or

- using "fedpkg":
yum install fedpkg
fedpkg clone -B perl-Params-Validate
cd f19
fedpkg mockbuild

Comment 5 Ralf Corsepius 2014-05-05 23:34:08 UTC
(In reply to Ralf Corsepius from comment #4)
> However, ... adding both "'globals" and "'globals'" works on f19, f20 and
> rawhide! I guess, I am going to add this.

I've applied this to perl-Params-Validate-1.08-7.

Comment 6 Fedora Update System 2014-05-07 03:48:49 UTC
perl-Params-Validate-1.08-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Params-Validate-1.08-7.fc20

Comment 7 Fedora Update System 2014-05-07 13:37:48 UTC
perl-Params-Validate-1.08-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Params-Validate-1.08-8.fc20

Comment 8 Fedora Update System 2014-05-17 06:30:18 UTC
perl-Params-Validate-1.08-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.