Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1094016 - [RHEVM-SETUP] - upgrade of dwh fails using previously generated answer file
Summary: [RHEVM-SETUP] - upgrade of dwh fails using previously generated answer file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks: 1100281 1105873 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-05-04 11:42 UTC by Barak Dagan
Modified: 2015-02-11 18:14 UTC (History)
16 users (show)

Fixed In Version: oVirt Beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1100281 (view as bug list)
Environment:
Last Closed: 2015-02-11 18:14:56 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
setup log + answer file (deleted)
2014-05-04 11:42 UTC, Barak Dagan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC
oVirt gerrit 27693 master MERGED packaging: setup: use db creds from answer file Never
oVirt gerrit 29768 master MERGED packaging: setup: test only config file db password Never
oVirt gerrit 29856 ovirt-engine-dwh-3.4 MERGED packaging: setup: test only config file db password Never

Description Barak Dagan 2014-05-04 11:42:09 UTC
Created attachment 892268 [details]
setup log + answer file

Description of problem:
Using 3 parts upgrade process (engine, dwh & reoprts frfom 3.3.2), craeting snapshot after each phase, the dwh patrs fails using the answer file, created before due to bad credentials (it works when rthe questions are answer manually):

[root@fire33-rep yum.repos.d]# rhevm-setup --config-append=dwh2.conf
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-dwh.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf', '/etc/yum.repos.d/dwh2.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140504135223.log
          Version: otopi-1.2.0 (otopi-1.2.0-1.el6ev)
[ ERROR ] Failed to execute stage 'Environment setup': Cannot connect to DWH database using existing credentials: engine_history@None:None
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140504135223.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140504135228-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


Version-Release number of selected component (if applicable):
av8.1

How reproducible:
100%

Steps to Reproduce:
1. install 3.3.2, engine, dwh & reports. 
2. upgarde engine to 3.4 (yum update rhevm-setup + rhevm-setup) and create snapshot
3. upgarde dwh to 3.4 (yum install rhevm-dwh-setup + rhevm-setup) & save answer file in different machine
4. restore 3.4 engine snapshot
5. upgarde dwh to 3.4 using answefile craeted in step 3

Actual results:
installation fails

Expected results:
Successfull installation

Additional info:
Step 5 pass by manual installtion

Comment 7 Yedidyah Bar David 2014-11-04 13:23:04 UTC
Not sure this requires doc text as it was already solved in the quite-old 3.4.1, see 3.4 clone bug 1100281.

Comment 9 errata-xmlrpc 2015-02-11 18:14:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.